ArduCopter-3.0.1 released!

ArduCopter 3.0.1 has been released and is now available in the Mission Planner,, GitHub and the new Downloads Area.

Warning #1: Compass calibration and reducing interference is far more important than with 2.9.1b

Warning #2: GPS glitches can cause sudden and aggressive position changes while in loiter mode.  You may wish to reduce the Loiter PID P to 0.5 (from 1.0) to reduce aggressiveness (see image below of where this gain can be found in mission planner).

Warning #3: optical flow is not supported but will be back in the next release (AC-3.0.2 or AC-3.1.0).

Warning #4: loiter turns does not maintain altitude.  This bug will be fixed in AC-3.0.2.

Warning #5: This release has only been lightly tested on Traditional Helicopters.

Improvements over 2.9.1b include:

  • Inertial Navigation for Loiter and Auto meaning much more accurate control (Randy,Leonard,JonathanC)
  • 3D navigation controller follows straight lines in all dimensions between waypoints (Leonard,Randy)

         WPNAV_SPEED, WPNAV_SPEED_UP, WPNAV_SPEED_DN, WPNAV_ACCEL allows configuring speeds and acceleration during missions

  • "compassmot" to compensate for interference on compass from the pdb, motors, ESCs and battery.  (Randy,JonathanC) (Set-up video here)
  • Safety improvements:
    • simple Tin Can shaped Geo Fence
    • pre-arm checks to ensure all calibration has been performed before arming (can be disabled by setting ARMING_CHECK to zero).  (video description here)
    • GPS failsafe - switches to LAND if GPS is lost for 5 seconds
    • stability patch improvements to stop rapid climbs in very overpowered or overtuned copters
  • Circle mode improvements including "panorama" when CIRCLE_RADIUS set to zero (Randy,Leonard)
  • SONAR_GAIN parameter added to allow better tuning of sonar surface tracking
  • CH8 auxiliary switch (same features as CH7)
  • works on PX4 (some minor features still not available) (Tridge,PatH)

How to upgrade:

1. Make sure you are using Mission Planner 1.2.59 or newer (get it here)

2. Click on the MissionPlanner's Hardware, Install Firmware screen.  The version numbers should appear as "ArduCopter-3.0.1", then click the appropriate frame icon and it should upgrade as per usual.

3. Reduce the Loiter and Alt Hold PIDs if you have modified them from the defaults.  The modified PID values for the 3DR frame can be seen in the image below.

Note: Nav parameters have been combined with Loiter so do not be concerned if you can't find them.


4. Although not directly related to this release, if you purchased an APM prior to March of 2013, update your PPM encoder to the latest firmware (instructions here).

5. Try out the new version in stabilize mode first, then alt-hold, then loiter and finally RTL and Auto.

Numerous How-To videos are available:

Special Thanks to MarcoDaveC and the large number of testers on the pre-release thread who put their copters at risk during the extended testing period.  Some of their videos can be found hereherehereherehere and here.  Thanks also to MichaelO for the MP changes required for this release.

All feedback welcome.  Please put your questions, comments (good and bad!) below.

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • Hi all,

    Need some advice!  I have upgraded to 3.1 rc7 and flown flown it successfully a few times.  I have a few issues:

    1. My compass calibration for the offset x = 201 (a little high), can't seem to get it lower, using the internal compass, maybe the external is the answer?

    2. When I power my quad up I get a pre arm failure : mag field, the mag-field shown in the status tab is 61, should I be getting a pre-arm failure if the mag field is low?  If I move the copter a few feet the mag field increases to 150ish and the mag field pre-arm stops. This may be caused by local area mag interference??

    3. My minim osd extra no longer displays data over the video, it was working before on 3.0.1.  I have checked the SR0 and SR3 parameters to match the wiki and also have selected the osd button in mission planner setup with no luck.  Any ideas?

    Thanks for the hep!

    Well done to all the Dev's apart from the minor issues above my copter fly's like a dream.

  • Arducopter 3.1 rc7. Found I had to drop the Stab P down a bit after autotune this time was 7.6 and dropped back to 5.


    Then went train spotting...


  • Is there a delay when switching flight modes in RC7.

    I noticed a drop when I switched from stabilize to althold.

  • What’s the latest estimate on the next general firmware update? Is their any hope of me getting it to use for the holidays?



  • Hello guys!

    I'm building a hexacopter with APM2.5

    This morning I tried the first flight, and I realized that the throtle goes crazy for moments. Even so, I continued trying flight until the motors were put at full speed and the hexa crashed into the roof...

    My setup is:

    motors robbe roxxy 2827-34 760kv

    RCtimer ESC Simonk firm 30A

    frame Mirkokopter.

    Can I know if the ESC are corrupted with the log?

    I attached the LOG.

    Best Regards

    2013-11-26 13-49 5.log

    2013-11-26 13-49 5.log.gpx
  • Not sure if this is a problem but it sure scared the BeJesus out of me.

    I wanted to compare the motor test sequence on my quad that has RC7 to a larger quad (X650)  running 3.0.1  to see if the sequenced matched both configs. I left my blades on the smaller X350, went into mission planner, went into the CLI, while waiting, i hooked up my battery for the motor test. Normally i hold the X350 down with my foot on one of its legs.

    its a good thing i did, because as i turned to look at the CLI, the Motors revved up to mid throttle and wouldnt turn off. my radio was on, the USB was in the Quad and the battery was connected. i had to turn the X350 into the ground to where i could disconnect the battery. maybe we should note on the CLI page that it would be a GOOD idea to do this test with No Blades on.

    the videos on the page show blades on, i naturally never thought the Quad would behave that way. i believe this was before going into setup as the CLI is connecting to the Quad, there was just binary code typing across the screen.

    also as we're on the subject, the way the CLI spins the Motors is the way the APM 2.6 board expects the motors to be configured? at first, on the X650, my props tested top right, bottom right, top left, bottom left. this isnt the way the XAircraft manual portrays the connections as it shows the motors in a counter clockwise config? 


  • Hello guys. I need some help.

    I am using the latest fw rc7....

    I have installed the ext mag too.

    after flying 15minutes on compass learning. I`ve checked the offset numbers...

    they are low as 40,42 and 6 on z axis.

    Mag interference is oscilante from 180 until 330.

    All cables are pretty twisted. Opto esc, external bec, servo wires and power lines all twisted.

    Ext mag and gps 10cm away from power lines. FC is 4cm away from power lines too.

    I don't know what to do anymore, I always have the message "bad compass health"....

    in the previous 3.01 I don't have that message.

    any clue?


  • Developer

    FYI, I've been chasing a problem for the past few days with missed GPS messages.  These are what we saw in John's logs and was one of the reasons I pulled -rc6.  -rc7 deals with these missed messages so you generally won't notice them but I wanted to tell people how to spot them in any case...maybe with the hopes that extra data points will lead to the cause (and thus solution).

    You can see them by loading up a flight's dataflash message into either the mission planner or excel.  If you're using the mission planner then you should filter to only show the GPS messages (see orange X in the pic below).  If your ublox GPS is working perfectly then all messages will have the "TimeMS" spaced 200ms apart (except for times where it's interrupted by you arming or disarming the copter).  If there is a missed messages then the spacing will be 400ms.

    3692886597?profile=originalActually an even faster way to find out if you had missed messages is to filter for the "PM" message and check the INAVErr column.  If it's all zero then you had none.  Generally if there's a missed GPS message you'll get about 20 INAV errors per missed message.  20 sounds like a lot but that just means it went 0.2 seconds (i.e. 200ms) without an up-to-date GPS message.

    3692886769?profile=originalAnyway, if a couple of people could check their logs to see if they're seeing this I'd greatly appreciate it.

  • i Wonder what kind of controller they use

  • 4 simple safety features:

    -In case of failsafe the beeper should be active

    -for maintenance it is useful a Total Flight Time parameter.

    -Mission Planner should have a text box to fill in last known coordinates from OSD and show them on map.

    -auto detect hardware failure - inability to control pitch/roll (prop-esc-motor) and shut down all props even in flight.

    other easy tasks:

    I need a Name prameter for all my copters. The logs should start with name and SW version, not only  SW.

This reply was deleted.


Santiago Perez liked Santiago Perez's profile