Yes my quad copter flue away a couple of week ago. I have contacted one of developer in the arducopter team, he gave me a mail address to send the flightlog file to so he could have a look at it, but now almost 4 week gone by without any answer,  and I don’t know way they don’t respond. So I thought I poste here to see if any of you guys have any idea of what could have happen. I poste a link to YouTube of a video I made from the flightlog file in mission planner so you can see what happened.


For the record this post isn’t to complain on the arducopter team or anything like that, I just want to know what happen.  I don’t dare to test auto mission again until I know what went wrong. Link to video on YouTube.



Some comments of what happen in the video.


So is there a software glitch/bug in arducopter 3,01? Look at the video and judge for you self.


The mission was just setup to follow the street you see in front of my house. Just a short trip over 8 waypoints at a speed of 3m/s. And at a height of 30 meters.


0,15: Start the copter up I tried loiter for I wile to see if everything seem to be working fin, and it did, a lite wobbly because it was lite gusty out but nothing major.

0,44: Switch to auto.

0,55: the copter reached waypoint 1 ok, and went of to waypoint 2.

1,03: Here I Starts to go south, the copter start roll heavy to the right and took off in very high speed well over 3m/s (21 m/s according to telemetry as you can see). I admittedly switch to RTL (as you can see), but nothing happens. And as you can see I have lost GPS 3D fix, and that’s was propyl what starts all of this. But should the copter just stand still if it lost GPS signal? It isn’t supposed to just fly away, right?

1,15: I then switch to AltHold. And try to fly it back but it did response to any stick command from the radio at all.

1,35: It got GPS 3D fix again, and I just took off in high speed again, no control of it at all. Note the mode was set to AltHold, not any GPS mode (Loiter or Auto etc.). So way did I take off when it was in AltHold mode? It sudden have matter that it got GPS signal when it wasn’t in any GPS mode??? And way in so high speed? And again it didn’t responded to any stick command from the radio, the only thing it seems to respond to was when I switch flight mode on the radio.

2,15: In some desperation I switch off the radio, I have set failsafe to RTL. And I have tried it before and it worked fine. At this point I didn’t know what else to do. And as you can see it went into failsafe mode and flight mode switch to RTL. Way didn’t it RTL?

3,10: And here it stayed hover, I have set no WP or nothing like that here. And you see the flight mode is in RTL.

5, 15: You can fast-forward to this point, I have zoomed out just to let you see that I knows where “home” is, and it also have an accurate distance to home. And the flight mode was RTL and it hade GPS 3D fix. Way didn’t it RTL????? Way did it just stay at that point???

6,22: I suddenly lost telemetry data and you could just barely see it visually. So I took off in a hurry by car to the outer side of the river to get telemetry to work again but I never did. So the copter had already crashed when I arrived or it had took off again. I never found it unfortunately.



The only explanation I can come up with is there some software glitch/bug….Hope to see some comments from you guys to hear what you think….


The copter was a quad copter with APM 2.5 and arducopter v3,01. And I use Futaba FAAST 2.4 GHz for radio and receiver (futaba original).


Sorry for bad English.

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • Just a wild guess, here, but I'm wondering if the huge DistToMav value played a part?  When it RTL'd, if it was trying to go to the MAV location, that might explain why RTL went flying off in some random direction...

  • My hexa just FLY away from me and LOST!!

    arducopter 3.1.rc5

    apm 2.5


    gps lock (solid blue led and wait for about 1 minute)

    stabilize - loiter ( not too bad ) - stabilized ( suddenly fall to floor) and motor spin very faster - and fly away-- cannot respon any mode( RTL - stabilized)

    T_T so saddd

  • This is interesting, upcoming version of Arducopter seem to have GPS glitch protection. This would have saved my copter for sure. Its really grate that this seems to be implemented, will safe many copter I thing.

  • there is seemingly something is strange.

    yesterday i had my first fpv test and beforehand i wanted to test the loiter and rtl.

    so i waited for the gps to get fix. it got 9 satelites.

    the i armed and waited a few seconds. the airborned and clombed a bit for 5-6m high and swithched to loiter.

    the suddenly the quad wanted to fly away because of lost ALL satelites (blue led blinked again).

    after landing it got 3d fix again.!

    this was occuring 2-3 times subsequently then it was good for the entire flight.

    after changing the main battery for new session the same issue scenario was occured....


  • I changed the mount on my quad from mounting tape I'd gotten at Lowes to a vibration dampening gel and that improved things quite a bit. I also made sure none of the wires or peripherals were near the APM, because even having a wire touch it would cause big spikes in my vibration logs.

    I haven't had any flyaways since but I'm still very much skeptical.  Reading these stories of drones going crazy is bad.

    This is one reason I feel people are being far too generous when they say APM requires a lot of "tuning". You tune a piano, a radio, the PIDs.  You don't "tune" something by sticking it up on posts with O-rings or cubes of gel or ear plugs. That's "rigging it" and it seems that that's expected with the APM. I keep comparing to the old Atari or Nintendo where you have to blow in the cartridge 3 times, have one side your console propped up on a VHS tape, and smack the side 3 times before turning the power on. That's what the APM is like. When NAZA messes up, you can almost guarantee it's pilot error; they didn't calibrate or changed a setting they shouldn't have. With APM... you're lucky if it's not some stupid hardware issue. Vibration, GPS glitch, light hitting the pressure sensor, and a host of other things.

    Internal dampening is a must if APM wants to keep up or, rather, catch up. Seems like they've come a ways but still have a ways to go.

  • interesting guys, I have a large octo on 3.0.1 and the other day it too took a very large leap towards me, I quickly switched back to stabilize mode and had control. This was scary, I will dig up the log if I can...
  • Here is what mine did yesterday : APM 2.5 Firmware 3.01

    people with NAZA 2 were laughing at me!

    LOGS and PICTURE attached.


    Here is more details:

    I lost control on my hexacopter  (  Sep /2 /2013 ) :

    EQUIPMENT:  APM 2.5 + 3DR GPS  + 3DR power module

    FRAME DJI 550 , charged LIPO battery 4000mah 4s.

    I had 7 flights yesterday with Firmware 3.01 7th was not so lucky.

    I always wait few minutes after changing battery for system to stabilize and pressure sensor to get stable.

    I tried modes : STABLIZE , ALT HOLD, RTL, LAND,  AUTO with 4 waypoints, LOITER. I also tried FENCE option with ALTITUDE and CIRCLE.  Everything worked BUT  on 4th flight when I switched from STABILIZE to RTL  ( my copter was very close to lunch maybe 3 - 5 meters ) it started a wide circle and flew away with no control. I suddenly switched to STABILIZE and it stopped. I could take over.

    On 7th flight, I started with STABILIZE and I increased altitude to MAX ( I was trying to see how FENCE will work. )

    I increased altitude just above HOME position then when it hit the MAX ALTITUDE it should RLT and LAND  but again it went with wide circle and flew away. This time with great speed and far. I switched modes between STABILIZE - ATL HOLD - LAN to gain the control but it was far  about 100 meters out and 40 meters high. I am attaching my logs here .

    as far as I can see : GPS reception was OK, battery voltage OK.


    I have my APM in box located BETWEEN upper and lower plates of the frame which means that it might me susceptible to a lot of electromagnetic field, magnetometer was calibrated and hexacopter was flying fine.

    2013-09-02 13-56 7.log

    2013-09-02 13-56 7.log.gpx

    2013-09-02 13-56 7.kmz

  • Ok I have an update on this. And sorry for late replay. I have received answers from Randy of the arcupilot/arducopter team now. And this is how I understood his answers.


    At the beginning of the video when it all start going south and we can see it lost GPS 3D fix. Before the copter lost GPS completely it’s started reporting very bad positions (according to log), and that is probably the reason for It all of the sudden start to roll heavy to the right and took off. When the copter then stop at about 1,20 into the video and start hover at that position for a while and then took off again. Here am I not exactly sure what happens, because what not make sense to me is that the copter was in AltHold and shouldn’t have bothered at all with the GPS signal, and therefore not have taken off again. But maybe it something I have missed about the flight modes, I don’t really know?


    And finally at the end of the video when the copter stood still in RTL and didn’t return. When the copter took off in high speed earlier I turn down the waypoint speed (I have set ch6 to manage the WPNAV_SPEED) because it speed away, and I don’t remember but according to the log I turn the speed all the way down to 0. Because I have set the MIN value of the WPNAV_SPEED to zero. Way I have the MIN value set to zero is because I find it very useful when I have live video stream and you or somebody else looking want to see at certain spot more, you just turn the waypoint speed to zero and the copter stays hover at that location until you turn the speed up again and it continue with mission.


    But what I didn’t know was that when the failsafe kicked in it caused the target waypoint speed to drop to zero, and that’s way the copter didn’t RTL. If I only have known then, but I didn’t. Randy has started at treed about this issue here,


    So my one conclusion is that it’s probably not a software glitch/bug, but a chain of unfortunately circumstances. And my own lack of knowledge how things worked with the setup.  So now I dare to fly my hexa with APM 2,5 again J

    But I do think maybe some software fixes/changes need to be addressed.


    And according to Randy it will come fixes/changes. One at least, and that is a fix so the tuning stops when the throttle failsafe begins, he said.


    And he also mention that they have some ideas for ways to check if the GPS positions is bad by example looking for unrealistic jumps in position and so on. But as he also said this are not implemented nor tested yet so.


    But I think this all I good news, they are relay trying to fix these issues so these think can’t happen again.


    And thank you guys for your response, and also for the kudos about the copter. Thank you.

  • Is it possible your APM came loose and tilted?  Could that explain why it flew away then did not come back in RTL?  it thought it was coming back and couldn't exceed the tilt angle?  that would be a odd coincidence though.


    If there was no wind, could that explain it moving in alt hold?


    How does flying over a body of water affect a barometer?  I wouldn't think it could cause a change to altitude like that.


    also, can you trust that it went 21m/s when you lost gps?



  • I've also had issues with my quad losing control during auto mode; on at least 3 occasions it flew fine to a couple of waypoints and then starting climbing full throttle for no reason. I'm going to try some vibration dampening, but I'm skeptical. It really does seem like a software glitch, but maybe the vibration is what's causing the software glitch. Hard to tell.

    Luckily each time I switched back to stabilize and was able to recover every time. But it could/should have been bad. I should have a few dampening options coming in the mail this week, so we'll see if it helps.

This reply was deleted.