10 days ago recently bought a new Pixhawk intended for use with a flying wing, and a Futaba R7008 receiver.

When I first got it I loaded all the firmware onto it fine using Mission Planner  (on a mac in Parallels XP) and all seemed to work well.

I then tried to connect the receiver, a Futaba R7008, and had trouble seeing the transmitter in Mission Planner (in fact I couldn't at all). On reading threads in this forum and others I then found out that there were lots of people having problems with Futaba R7008 receivers with pixhawks and that it had only just become compatible in the latest code.

So I updated the pixhawk to newer firmware (Stable Version), this time in QGroundControl mac in PX4 mode, and managed to get it all working and calibrated the RC sticks and everything fine.

Then after working fine for a while, the next day the RC transmitter seemed to stop being recognized again, for no apparent reason. So I tried various firmware upgrades again, variously in Qgroundcontrol (Continuous Build, Beta Build, Stable Version again), then  in APM Planner 2.0rc5 (which crashes endlessly so i gave up) and then Mission Planner 1.2 on XP.  But now the pixhawk seems in pretty ill health and the IO side of it doesn't seem to function at all well.

Now when I boot up the Pixhawk (say after reflashing from QGroundControl), both green power lights come on, the FMU orange led flashes for a bit then stops, and that's it.  There are no lights on the IO side like there used to be apart from the green power LED. The orange and blue LED's no longer light up (as they used to a few days ago), and there is no LED light on on the safety switch anymore either.

When I do a clean flash with Stable firmware Version from QgroundControl in PX4 mode, the accelerometer works fine and I can connect and see tilt etc.. But it does't make the successful startup sound noise. If I then check the Boot.log file on the SD card it says "PX4IO board not found", even when I clear the SD card, delete all files, and do a fresh firmware upgrade, this  Boot.log file reappears and the "PX4IO board not found" message inside it.

What have I done with all my fiddling? Is there a way to reset the Pixhawk to factory settings? It is strange because this Pixhawk I have seen working in all it's glory, but for the moment it seems a bit bricked!

Thanks in advance for any ideas

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • I had the same problem.  A brand new, perfectly working Pixhawk, first thing I did was to "upgrade" the firmware which bricked it.  In my opinion, developers should inform people before updating that Pixhawk is not compatible with the latest firmware.  It will NOT encourage me to buy a Pixhawk 4.

  • I had similar problems using qgs. I flashed px4 using mission planner and everything works fine.
  • What kind of transmitter use with R7008SB?  And what is transmitter firmware version?

    • Transmitter is a Futaba 14SG with firmware 3.0.  However whilst I have been trying to get the pixhawk working again I have completely disconnected the R7008SB until I can get pixhawk up and running again. The only things connected to it at the moment are the buzzer, and safety switch.

      • hmm  

        I have same Futaba 14SG V3 firmware and R7008SB but do not detect rc signals in S.BUS/S.BUS2 mode.

        When you update px4fmu-v2.px4 after restart do you have successfully update tone?

        • no i don't get successful update tone after restart doing that.

          • Follow up.... FYI, 3DR seem to think that the two last beeps indicate a fatal hardware issue. So there we have it. Back to the factory!  Thanks anyway xian.

  • PX4IO SDCard Update:

    Download  px4io-v2.bin    http://firmware.diydrones.com/PX4IO/2014-03/2014-03-02-22:03/PX4IO/

    Copy to Pixhawk SDCard

    Press and hold Safety button and power up Pixhawk

    • still no luck either I'm afraid Xian....  It tried to play startup tones but then they were interrupted by 3-4 long low tones.

      And the bootlog on the SD card afterward now says:

      PX4IO Trying to update
      PX4IO update failed

This reply was deleted.