minimosd requires xbee to connect to get (accurate) telemetry data


at initial APM/OSD/xbee power-on, the OSD gets some data from the telemetry but this isn't completely accurate. Once I "connect" the Mission Planner with an xbee on my laptop to the APM, the telemetry starts to display all the data (and accurately).

I've tried powering up without the xbee present, and this makes no difference - the APM must still be connected to the mission planner first before telemetry is received.

I'm powering the OSD via the 12V side, i've got the 2 blobs soldered on, and have only the RX and GND lines connected on the APM side of things.

It would be nice to be able to get OSD data without having to use a laptop each time I want to fly... does anyone have any ideas?


Views: 3178

Reply to This

Replies to This Discussion

I should have added... power cycling OSD doesn't resolve it, disconnecting telemetry data just gives the "waiting for heartbeat", and once connected, the data is either absent (or wrong)..

AFIK, that is the correct behavior when the xbee and osd share the same APM port, and the osd does not have the TX line connected.

The Mission Planner sends a data request to the APM when you hit the Connect button.  This starts the sending of data from the APM.  Since the osd does not have the TX line connected, it is just listening to the data passing over the xbee.

The only way I know of to have both working independently is to have them on separate ports, both the xbee and the osd will each have their own TX and RX.  The xbee transmission to the MP will be started when you connect, the osd will start immediately.

I need my OSD to work by itself as I don't always haul a laptop around when I fly, but I also have a 3DR radio, which I need to work when I do bring the laptop.

I'm thinking that maybe if I rig up a hard switch, so that when it is one position, it will connect the TX of the minimOSD to the uart0/2 port, and when the switch is on the other position, it will disconnect the TX pin of the minimOSD. Would this work?

The minimOSD sets the APM up to send data when it's starts. You can do this by connecting the TX line from the OSD


You need to set these advanced params to get the APM to send telemetry data with out the GCS making a request.



To confuse this problem the documentation for the jDrones io board instructs to connect the Tx to three devices at once. This is in conflict with the instructions for using minimosd with data-TRx, which says to only have the Tx connected to one device.

Thanks for the reply. I've just tried setting the following params from there, but my minimOSD still doesn't update until I connect mission planner via the 3DR radio. I'm running minimOSD firmware v2, still have the tx line disconnected on it.

SERIAL3_BAUD, 57    (telemetry output at 57600)
SR3_EXT_STAT, 2      ( 2hz for waypoints, GPS raw, fence data, current waypoint, etc)
SR3_EXTRA1, 5         ( 5hz for attitude and simulation state)
SR3_EXTRA2, 2         ( 5hz for VFR_Hud data )
SR3_EXTRA3, 3         ( 3hz for AHRS, Hardware Status, Wind )
SR3_POSITION, 2      ( 2hz for location data )
SR3_RAW_SENS, 2  ( 2hz for raw imu sensor data )
SR3_RC_CHAN, 5     ( 5hz for radio input or radio output data )

Does anyone successfully have both the tx pins of the 3dr radio and the minimOSD connected? Does it cause any problems with the radio (or the OSD?)

The only other issue that I can think of is that you need to connect CTS line, if I rember it's high. On the APM telemetry port. You could check to see if there is a difference when you have the Xbee connected or not. If the APM is checking CTS it will not send data until its set correctly.

So you mean I would need to connect the CTS line on the minimOSD? Where on the APM2 Would it need to be connected to?

I just check the eagle files and there is no CTS line to connect too.

I would advise trying the standard no telemetry setup with the tx line connected and see if you can make it work that way. Then we can figure out why it's not working.

I was thinking that maybe connecting the miniOSD up by powering it with 5V from the APM, and not connecting the 12 line to the board.

see the second option (critical power). If you are using the APM 2.5 with APM Power Module and JP1 removed, you won't get any servo noise as they are disconnecting by JP1.

(PS: do you have a way to measure using a scope (best) or a multimeter the voltage levels on the RX pin with and without the XBee connected? )

Sorry I'll back up a little.

My minimOSD works fine if it is the only device connected to the APM2 and has its tx line connected to the rx pin on uart 0/2. The minimOSD is currently only powered by the 5v line from the APM2 and the 12v pins are disconnected (its a v0.1 board and overheats if the 12v lines are connected).

I'm just in the process of wiring up a two position switch which will switch between the tx lines on the 3DR radio and minimOSD, so if I'm flying without the laptop/radio, I'll just flick the switch to connect the minimOSD's tx line to the rx on uart0/2 and disconnect the radio's one.

Ok, very interesting.  Did you have this issue with 2.8.1 or is it new to 2.9?  It could be new to 2.9 because we removed some extra data-send messages.

In 2.9.1 we can add a checkbox into the Hardware screen of the mission planner so that the APM always sends attitude data out on the serial line even if it doesn't see a mission planner connected.

Hi Randy, I hadn't used 2.8.x, and only just got the 3DR radios now.

That would be good to add into 2.9.1. That would be different to adding the SR3 data rates like I tried a few posts down though right?

Reply to Discussion


© 2018   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service