Hello. I have an APM 2.5 with MinimOSD. I can get my MinimOSD to function properly if my camera is unplugged. However, as soon as my camera is plugged in, I get great video, but no OSD text overlay. If I unplug my camera, me text comes back (with a grey screen behind it).

I've checked my cabling and everything appears in order.

I've reinstalled my firmware 2.0 and OSD Extra 2.1. I've also updated my character set. When the camera is off the OSD is functioning perfectly (no fuzzy or malformed text). It's like the OSD will transmit either the text or the video, but it won't overlay the text over the video.

I've also tried powering up the OSD is every possible order I can think of.

Any ideas?



You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


    • Bah. I couldn't find a solid answer, so here's what I did.

      I just put a switch in the power line between the fpv camera and minimosd. I just quick cycle the switch before flight, and voila.

      Crude, but it works, and i'm flying. 


  • I have been having the same issues.  However if I plug my FPV camera in after powering the system up I get video and overlay.  If I power them together, just video. I found if I also unplug video out and plug it in the overlay comes up.  Using the reset button sometimes helps too. 

    I am unsure what the problem could be?  As a short term fix I can plug the camera in after but I wonder if I could lose the overlay in flight.  I will try a RC video source switch to see if that helps get it back if lost. 

    • Did you guys ever figure this out? I just swapped fpv camera from fatshark 600tvl cmos to rmrc 420 ccd, and I lost all video overlay.

      If I unplug the camera and replug it in, the OSD comes on very faintly. If i power cycle the entire multirotor, it will not show up again. 

      I am not running a shielded cable, and I am powering the VTX side with 5v from immersion/fatshark VTX. But I never have before either.

      • I've had lots of weird problems with the MinimOSD, but they disappeared when I started using the 5V from the ardupilot to power both sides of the card. But I'm using a 12V 600 tvl camera...

      • Try hitting the reset on the minimosd after you powerup and if your having camera/minimosd problems. I cant remember the exact cause that problem fixed but its an easy thing to try and cant harm.

        • I have tried the reset button. No dice.

          I have just tried a shielded cable. No luck there either.

          I also have tried to change settings in the camera itself, baud rate and etc. no luck.

          then I tried switching the minimosd to PAL from NTSC. No luck. switched back to NTSC.

          Then I plugged in the old cmos camera (which I hate because its soooo sensitive to vibration), and voila. overlay works perfectly.  

          Plug in the CCD camera, faint overlay, and if I power cycle the aircraft, no overlay. I have to unplug the camera and replug it in to get the overlay to come up....

          any ideas? I'd really like to use this 480 line rmrc fpv ccd camera...

  • I seem to have the same problem. I am not running shielded cabling. 

  • What I did was twist all camera wires and I bypassed the osd with the positive wire and powered the osd with the 5v on the other side. So only video and ground is connected to the osd
  • Thomas,

    I am having the exact same problem. Video and no overlay- unplug the camera and you get the overlay.

    Did you solve your problem? I sure would like to know.



  • I solved my similar problem by changing from shielded to unshielded cable between the camera and OSDMinim. I have no idea why it helps... (I would have guessed that shielded would be best; but not in my case...)

This reply was deleted.


Chris Anderson liked Zara Mae Pickering's profile
May 21
Azjeg liked Azjeg's profile
Apr 27
Benewake LiDAR liked Benewake LiDAR's profile
Apr 12
Gremsy liked Gremsy's profile
Mar 12