New mission planner compass calibration

I have been unable to successfully perform a compass calibration since the latest update of mission planner. Each time I try, I get a message stating words to the effect "data not collected for all directions"When I attempt the calibration, I end up with a sphere of colored dots, an everything appears to be working normally. I have tried both the "compass dance" and Randy's technique but so far no success.Anyone else experiencing this?

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • Is it just me or should the motor calibration gui in MP be interactive and plot the mag interference as you raise the throttle. I clicked on START, slowly raised the throttle to 50% and hold for 5 then a click down to nothing and the graph never jumps ?

    When i did it the old fashioned way via the terminal i get a compassmot of about 1ish% with no props but still i expected something on the graph.

    • It may only be working with Arducopter 3.2.  I remember trying it a couple weeks ago and it did nothing (using the page you described). I just put 3.2dev on my copter and now it works and updates live.

      Just for clarification for anyone that reads your post.... a compassmot without props is not useful since it will not draw the same amount of current with props, which is what induces the compass error and determines the compensation values.

      • I apologise if this is a bit off topic.

        My mission planner just updated to version 1.3.0.

        Now, I do not have a "Terminal" icon in the upper tool bar area.

        I am new to MP and the whole APM thing (getting up to speed quickly though).

        Am I just not looking for the obviuos?

        Thanks.....

        • I found exactly the same thing - Terminal has disappeared, along with other menus which used to be visible from the 'quick' section of Flight data.

          • I'm told there is provision to select "advanced menu" or similar and an expanded list of options will display.
            • I cannot see any "Advanced Menu" selection. Unless it is hidden with the Terminal selection..LOL.

              Right clicking on the top tool bar just opens 2 options to select:

              Auto Hide    and   Full Screen

              • Under the Config/Tuning tab, bottom right, check "advanced".

                That also will bring back some of the tabs in Flight Data.

                • Aha, that did it. Thanks.......

  • Developer

    What we have now is a much more comprehensive compass calibration with feedback so you can see the directions that you have pointed the vehicle.  Spin the sphere around and make sure you have coverage in all quadrants.

    • Do you need to be outside away from buildings and metal or can you do it inside? I tried at the field but it was too tough to see the screen.

This reply was deleted.

Activity

DIY Robocars via Twitter
May 15
DIY Robocars via Twitter
May 14
DIY Robocars via Twitter
May 13
DIY Robocars via Twitter
RT @f1tenth: Say hi to our newest #F1TENTH creation for @ieee_ras_icra next week in Philly. It’s going to be huge! 😎 🔥 @AutowareFdn @PennEn…
May 13
DIY Robocars via Twitter
May 11
DIY Robocars via Twitter
May 8
DIY Robocars via Twitter
RT @SmallpixelCar: Noticed my car zigzagged in last run. It turned out to be the grass stuck in the wheel and made the odometry less accura…
May 8
DIY Robocars via Twitter
RT @SmallpixelCar: Test my car. RTK GPS worked great. Thanks @emlid for their support. https://t.co/EkQ6qmjmWR
May 8
DIY Drones via Twitter
RT @chr1sa: @kane That's @diydrones circa 2009. Still have a box of those Canon cameras that we used to strap into planes, just like this.…
May 3
DIY Robocars via Twitter
RT @chr1sa: Our next @diyrobocars race is going to be outside at a real RC racetrack in Fremont on May 28. Fully autonomous racing, head-to…
Apr 30
DIY Robocars via Twitter
RT @f1tenth: Our Spring 2022 F1TENTH course @PennEngineers is coming to an end with a head-to-head race as a big finale. So proud of our st…
Apr 26
DIY Robocars via Twitter
RT @DanielChiaJH: I wrote a thing! Throughout the development of my @diyrobocars car I've been using @foxglovedev Studio to visualize and d…
Apr 23
DIY Robocars via Twitter
RT @SmallpixelCar: My new car for high speed. Low body, everything ( @NVIDIAEmbedded Jetson Xavier NX, @emlid RTK GPS, IMC) under the deck…
Apr 23
DIY Robocars via Twitter
Apr 21
DIY Robocars via Twitter
RT @f1tenth: F1TENTH Race training setup @PennEngineers for our upcoming ICRA2022 @ieee_ras_icra competition. @OpenRoboticsOrg @IndyAChalle…
Apr 21
DIY Robocars via Twitter
RT @fatcatFABLAB: Proud to be hosting a restarted DIY Robocars NYC Meetup April 26. Come by if you want to talk about and race self-driving…
Apr 17
More…