Pixhawk causing motor sync issues.

I believe I have a problem with my Pixhawk and was hoping for some help.  Also posted this on rcgroups.

The issue is that when my speed controllers are hooked up to the Pixhawk they exhibit a bad sync issue.  However when they are connected to my old APM (3.1) or just a receiver directly they do not exhibit these symptoms.  This has resulted in 4 crashes now until I just tonight narrowed down the issue to the Pixhawk.

Can anyone advise what is going on?  Here are the specs of my setup:

Afro 30A ESC's with SimonK firmware (have tried all versions, and made my own with various parameters)

Tiger MT2216-9 1100kv motors

4S 3700mah battery



You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


    • ESC compatible with Simon k are not compatible with bl heli chips are differnt on PCB . This is a known issue one way to test to see if really sink issue do compas mot test all motors should spin at the same speed if not get rid of Simon k ESC try BL heli .
    • Developer

      My guess would be there are between 120,000 and 150,000 Pixhawks happily flying around while connected to Simon K ESCs.

      Wiring your ESC correctly to the Pixhawk fixes the problem.

  • I posted this elsewhere with no responses. I'm hoping someone in this thread can help me.

    I too am using Afro 30A ESCs with my Pixhawk. I had a crash and I can't tell if it was a motor sync issue or not.

    All was going well until I switched from loiter mode to stabilize mode. My throttle lever was a little low when I switched to stabilize mode, so the copter started descending.
    I increased the throttle to compensate, but nothing happened. When it started falling faster, I went to full throttle. No response.

    My Setup

    • Pixhawk running Arducopter 3.2.1
    • Afro 30Amp ESCs
    • 800KV TMotors
    • 12X3.8 props
    • 4500mAh 30C battery

    I've attached the log file from the incident. Can someone with more experience have a look and see what could have caused it? I'm thinking it's the ESC's.


    • It doesn't sound like it was a sync issue. 

      Unfortunately I can't read that bin file (I'm not sure if it's corrupt or didn't upload properly.  Can you please zip and attach the .log?

      • Thanks for the reply. I've attached  the log file.

        Any help is greatly appreciated! Thank you.


  • The programming connector looks to have all three wires. Connect signal ground there to your controller?
  • I just ordered the Rotorgeeks BLHeli 30Amp V2 ESC. They don't even have a signal ground.

    Are these safe to use with the Pixhawk? Mostly everyone in this thread says you need to connect the signal ground. Why would the Rotorgeeks ESC not even have a signal ground!

    This is what I ordered: http://rotorgeeks.com/index.php?route=product/product&product_i...

    Bummer! What do I do?

    • I trying to use these RG ESCs with just the signal wire (one of them has the ground and it is connected) and i cant complete the ESC calibration and the PixHawk aways ARM but sometimes de motors spin sometimes not.

      I'm not sure what is the problem. The other 3 ESC grounds missing or something in the BLHELI values that compromisses it.

    • Its been a while since I posted on this blog ...but I wanted to share my experience using the afro30Amp esc's with the T-motor Mn3508-580 Kv motors with 13x55 CF props powered by a 4S lipo...initially I faced serious problems trying to get these ECS's to work with the Pixhawk...I had all of them flashed with BLheli and throttle rate at 255...PWM frequency at 16Khz motor timing with demag compensation enabled and Lightly damped mode selected....my Esc's are placed beneath the motors for cooling so the FC to ESC signal wires are very long at least 60 cms long....I had problems with the throttle getting stuck while testing for sync issues ...I have a video here which shows this https://www.youtube.com/watch?v=BfiL_wt22a0

      I had a tough time figuring this out and every time I thought of this issue the most common doubt in my mind would be that the signal reaching the ESC's is getting distorted to such an extent that the pulses can no longer be measured by the Hardware interrupt pin on the Afro ESC's....this problem is compounded by having high signal wire resistances due to long FC to ESC distances...even if these resistances are minute using aluminum servo extension wires or other non copper based extensions can exacerbate this problem....I tried using various servo extension but failed ...the other day that I got a suggestion to use twisted wire pair LAN cable wires .. these wires being reasonably flexible-ish are low impedance copper cored and are specifically designed to carry digital signals for relatively long distances without required intermediate repeaters....I decided to give them a try and THEY WORK AWESOME!!!....RC_SPEED set at 490 and with all the above Blheli setting I went crazy with Rate PID's tied my Hex to the ground and just threw my Roll/Pitch/Yaw sticks around....no sync issues ....motors follow the sticks ....no stuttering...no cogging...I have my hex up and running without any issues...but haven't run auto-tune...I just tuned my copter manually coz' I like my copter to feel the way I want it to.....and Autotune gains have been known to be a bit on the higher side..but you can do it if you like

      I would like others to try this out ...any feedback on this would be welcome         


      • AKcopter,

          Do you have a link to the LAN cable wiring you used? I am having sync issues still after all this time and 3 different ESC's (not including the 3DR ones from my Y6B).

        This is beyond frustrating. I calibrate the ESC's, everything seems ok then over time they de-sync again.

This reply was deleted.


Shivchand Jaysaval liked Shivchand Jaysaval's profile
Aug 25