Firmware, Bad motor, ESC?

Hello, I posted this as a reply to a previous discussion I had, but thought I would start a new one too.

I connected my 3DR Y6 to Mission Planner, hoping to check calibrations, and I noticed the top back motor wasn’t spinning.  I just recently (a couple months ago) replaced that motor because it wouldn't spin.  I did the necessary ESC calibration before replacing it, and it didn't fix anything, so I replaced it.  I did the ESC calibration again, did some test flights, and everything worked well.  I haven't flown for a while since, as the weather has gotten pretty frigid and snowy here. I'm wondering if the ESC has to be calibrated that frequently for the motor to spin?  It just confuses me because I had flown very frequently all summer with no problems with motors not spinning.  The other thing I noticed is there is a firmware update (V3.2). Would a firmware update have anything to do with the motors?  I didn't want to update yet in case anyone had problems with V3.2 so I thought I would check on here?  Any suggestions would help



You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • Ok, so here is my progress.  I updated firmware to 3.2.  It warned me that I had to perform the compass calibration. To be safe, I did compass, accel, ESC, and radio calibrations.  When I calibrated my ESC, I tested motors and throttled up and all motors spun.  After calibration, I powered everything up again, and armed the Y6.  When I went to throttle up to test motors again, it makes a low beeping tone, and doesn't let me arm.  I'm guessing it must be something simple that I need to adjust.  Does anyone have any suggestions or has anyone ran into this?

    • Did you have the craft in your hand when you tried arming it?  It needs to be level, so do not pick it up until AFTER you arm it...  And if you do, BE CAREFUL!  Those blades can be SHARP! (don't ask why I know...)

    • It was on a level surface, and everything started out well until I tried to arm, it just gives a low error tone. Thanks for the warning though!

    • What errors do Mission Planner report?


    • On the flight data tab, it says PreArm: Compasses inconsistent. I calibrated the compass before and after that, so I'm not sure if I need to keep calibrating or if I need to look into something else. It doesn't show up consistently.

  • I think I'm going to check on switching out the ESC based on what everyone is responding, and I will look into the PDB as well. Thanks for all your suggestions! I will post on here when I've completed the calibrations and fixes, I'm hoping to get it all squared away this week.

  • I have had this same issue.

    Luckily (unlike Raymond) I noticed the problem while testing and calibrating before flying. It was the PDB. The exact point of failure on the PDB I found I could not isolate, so I replaced the PDB rather than trying to fix it.

    The test I performed was to swap the suspect motor/esc to a different PDB output and see if the problem re-occurs


  • I'd suggest that before your get into tearing the copter apart that you redo ALL calibrations, »»especially the compass.«« I do it in the manual mode and don't stop till I have about 4000 points. This has the extra benefit of getting my GPS to lock much faster. Can't be sure but it might help your problem.

    And, while I'm sure you've already done this, be absolutely sure your props are of the correct type for the motor they're on and all have the writing facing up.

    I have no earthly idea how I screwed up this way but I managed, after checks and rechecks, to put the wrong prop type on one of my X8 motors.

    The thing kept flipping on liftoff. After I FINALLY noticed it was doing the same thing EVERY time I checked the props one more time and found an SF where an SFP should have been. Changed prop. Problem solved. Little things mean a lot. ;-)
  • Check the PDB (Power Distribution Board). I had a dry joint on mine that caused a crash.

    Latest crash - my Y6 just stopped in mid air. Still have to find time to check the logs and figure out what happened.

    Upgrade to v3.2 - new features like follow me work properly. You will need to recalibrate everything though (as per the v3.2 readme).

  • I had a bad ESC, and the motor not only would not turn, but it would also "stutter" when at slow speed.  Try switching motors and ESC and see if its constant with the motor or the ESC...

This reply was deleted.