Newbie here. 


Just purchased a ready-to-fly 3DR Hexa-C and installed drivers, downloaded and installed MissionPlanner-1.2.48 software.  Followed instructions to uploaded 2.9.1b firmware first before even thinking of selecting Connect button. 

Oh ya, I also verified correct Com Port, and bits per sec (115200) for both the com port and mission Planner.  The problem I see at or near the end of Read Hex File is a alert window "Communication Error-No Connection". 

At this point I have swapped USB cables 3x, uninstalled and installed  MissionPlanner-1.2.46, even uninstalled USB driver "Arduino Mega 2560" and installed arduino-1.0.4's driver.

Lastly, I opened the Mission Planner software and selected "Terminal" I observed "com port open" but was not able to send commands to module.

This was test on both my laptops (one I'm typing on is a Windows 7 laptop, the other was my Windows 8 laptop with driver signatures turned off.


What in the world am I doing wrong!  This should be this difficult.  Help!


Doug W.

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • Disabling all other COM ports worked for me too! Thanks for the info

  • Seems to me like there is a problem with the APM2.5. There is a lot of people on here with issues. I am one of them too. I've had to post mine back to be replaced with hopefully a 2.6. Mine was no heartbeats received also. Checked everything,it just stopped working for no gd reason. Just hope that the problem is resolved soon. Annoying I can't get flying.
  • After much troubleshooting and endless evenings trying everything under the sun, such as reformatting the notebook and installing Windows 7 and uninstalling the older version of Mission Planner 1.2.48 and installing 1.2.50.  I still had no joy connecting to the APM 2.5.

    Then I sat back and looked at the Hexa-C and noted that I had a stabilized camera platform with a gyro and a cable which was correctly connected to the Pitch Servo plug located on the bottom side of my copter.  So out of pure desperation, I decided to unplug it.  Low and behold!  The APM started talking to the notebook and Mission Planner.  At this point I do not believe the old version software was ever the issue.  It seems the Pitch Servo is possible pinned put incorrectly or the Turney TGY-90S is defective.

    Attached are photos of the camera stabilzed platform and its servo cable connector.  3692712675?profile=original

    Where do I go from here with respect to connecting the stabilized platform to the APM?



  • 3692712088?profile=original

    I have same issue since APM Planner 1.2.48 and AC 2.9.1b.

    Sometimes it is just "Connection Error - No Connection" and sometimes as on screenshot above.


    Telemetry, configuration and Terminal working fine, firmware load is broken.

  • Thanks for the suggestion, I have ensured the COM port settings are correct in the device manager. I am able to connect correctly to the APM to see telementry data and the terminal connects via USB.
    Any other suggestions? Cheers
  • Please report back which notebook computer you got to work.  I am also planning ot get a new notebook.



  • Hello,

    did you calibrate your own COM port (on the ground station) ?

    Use the periphals managements interface, find the COM port which is used to connect the APM and check if, in the properties interface, the baud rate is set to 115200.

    It is a serial communication. Both sides have to set their baud rate at equal value before trying to communicate.

    Then, you can connect the APM using Mission Planner (don't forget to set the correct baud rate and COM port).

    For the terminal, you have to connect first your APM then go to the terminal where you will see "COM port opened" and after a short time, Mission Planner will load the CLI Menu which is stored in the APM (so now you know why it takes some time to be displayed).

  • I am having the same issue when uploading Arduplane V2.72 from Mission Planner 1.2.48.  Please help.

  • Not sure this is you issue but If you were connected when you tried to load the firmware it will give you that error. Try disconnecting then load the firmware.

  • 3D Robotics

    Doug, did you download and run the Mission Planner installation utility, which should install all the necessary drivers?

    You shouldn't have to upload the firmware, since if you bought the hexa RTF the firmware is already loaded. Can you connect via MAVLink? 

    All RTFs are flown before shipping, so the hardware should be fine. 

    It might be worth trying another PC and doing the installation on that. Sometimes misbehaving antivirus software can mess things up. 

This reply was deleted.