Developer

ArduCopter-3.0.1 released!

ArduCopter 3.0.1 has been released and is now available in the Mission Planner, firmware.diydrones.com, GitHub and the new Downloads Area.

Warning #1: Compass calibration and reducing interference is far more important than with 2.9.1b

Warning #2: GPS glitches can cause sudden and aggressive position changes while in loiter mode.  You may wish to reduce the Loiter PID P to 0.5 (from 1.0) to reduce aggressiveness (see image below of where this gain can be found in mission planner).

Warning #3: optical flow is not supported but will be back in the next release (AC-3.0.2 or AC-3.1.0).

Warning #4: loiter turns does not maintain altitude.  This bug will be fixed in AC-3.0.2.

Warning #5: This release has only been lightly tested on Traditional Helicopters.

Improvements over 2.9.1b include:

  • Inertial Navigation for Loiter and Auto meaning much more accurate control (Randy,Leonard,JonathanC)
  • 3D navigation controller follows straight lines in all dimensions between waypoints (Leonard,Randy)

         WPNAV_SPEED, WPNAV_SPEED_UP, WPNAV_SPEED_DN, WPNAV_ACCEL allows configuring speeds and acceleration during missions

  • "compassmot" to compensate for interference on compass from the pdb, motors, ESCs and battery.  (Randy,JonathanC) (Set-up video here)
  • Safety improvements:
    • simple Tin Can shaped Geo Fence
    • pre-arm checks to ensure all calibration has been performed before arming (can be disabled by setting ARMING_CHECK to zero).  (video description here)
    • GPS failsafe - switches to LAND if GPS is lost for 5 seconds
    • stability patch improvements to stop rapid climbs in very overpowered or overtuned copters
  • Circle mode improvements including "panorama" when CIRCLE_RADIUS set to zero (Randy,Leonard)
  • SONAR_GAIN parameter added to allow better tuning of sonar surface tracking
  • CH8 auxiliary switch (same features as CH7)
  • works on PX4 (some minor features still not available) (Tridge,PatH)

How to upgrade:

1. Make sure you are using Mission Planner 1.2.59 or newer (get it here)

2. Click on the MissionPlanner's Hardware, Install Firmware screen.  The version numbers should appear as "ArduCopter-3.0.1", then click the appropriate frame icon and it should upgrade as per usual.

3. Reduce the Loiter and Alt Hold PIDs if you have modified them from the defaults.  The modified PID values for the 3DR frame can be seen in the image below.

Note: Nav parameters have been combined with Loiter so do not be concerned if you can't find them.

3691038784?profile=original

4. Although not directly related to this release, if you purchased an APM prior to March of 2013, update your PPM encoder to the latest firmware (instructions here).

5. Try out the new version in stabilize mode first, then alt-hold, then loiter and finally RTL and Auto.

Numerous How-To videos are available:

Special Thanks to MarcoDaveC and the large number of testers on the pre-release thread who put their copters at risk during the extended testing period.  Some of their videos can be found hereherehereherehere and here.  Thanks also to MichaelO for the MP changes required for this release.

All feedback welcome.  Please put your questions, comments (good and bad!) below.

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • please tell us why roll back ?

  • T3

    Congratulations to the development team, on a job well done!  Unfortunately I won't be able to test the new code for a few weeks, I'm vacationing in Brazil and my wife would not let me bring a copter with me. ;-(

  • Randy,

    I test flew my F450 quad just the other day. It was a super calm weather just after a heavy rain. I wanted to see the 3 modes (acro, stab. and loiter) when it wasn't windy out there.

    Acro and stab. modes did great. As soon as I switched to Loiter (I had a GPS lock), quad started climbing (not at a fast rate). I thought it would be the throttle_mid parameter issue. I lowered the throttle but it didn't stop the climb. I then turned it back to stab. I realized I didn't have a control. I panicked; switched to acro; still didn't have anything. No control what so ever. The quad was climbing at a steady rate. It was about 20 meters or so. I turned the Tx OFF; hoping that it would RTL land. It didn't do anything. I turned the radio back ON. Right at that second, all motors stopped in mid-air and the quad started to fall. With the fear of losing the entire platform, I didn't do anything and let it fall all the way down. Just about it hit the ground (grass surface), I attempted to fire up the motors to reduce the impact. Motors responded and slowed down the descent rate but it still hit the grass surface and flipped. Luckily no damage. I didn't even break the props.

    I tested the quad after that and everything seemed to be working fine. I didn't want to fly it but all controls were functioning ok. I downloaded the flash log; checked it for a while. I can't find anything. Or let's say I don't know what to look for exactly.

    Do you think you could take a quick look at it and let me know what happened?

    I test flew this quad a few times with same conditions and it was flying okay. I know my compass interference is very and I need to work on it but I doubt it has anything to do with what happened here.

    Would very much appreciated if you could take a look at it. I do not have telemetry; so no tlog...

    I want to know what caused the loss of control and what caused all motors to stop.

    Thanks...

    2013-07-12 20-19 1.log

  • I have found 2 conditions that will cause motors startup and tip overs on the ground: 0 altitude in a mission "takeoff" and "circle" mode mistakenly switched on while at 0 altitude..

    The team has done a fantastic job of protecting us from pilot planning errors but these 2 have bitten me recently.

    Is it possible to block arming if takeoff is at 0 alt and circle mode inadvertently started while on the ground?

    This latest version 3.01 is just fantastic.. Thanks

  • hi Randy

    what options used for official hex compilations?

    i tried to compile git code for quaid but my hex file size was large 

    #define DMP_ENABLED ENABLED  in official hex?

  • Trying to get my head around the fail safe setup here and after half a day of lots of reading I think I am making headway. 

    I have a Futaba 10CAG and using an FrSkye TFR8 receiver. Ive read that the TFR8 has a fail safe feature as well and they advise to disable FS in the Futaba TX if using this RXs fail safe so I disabled that in the TX. Thats all Ive done so far. I'm not sure if the FS on the TFR8 is on or off yet.

    But when I turn off the TX is see in MP the throttle drops to 900. I'm not sure if this is from the RX setting this or from the APM2.5 boards encoder. (updated to the latest fw version) 

    My question is, is this sufficient enough for the FS to work?  Is the setting of 900 from the APM or the RX and how can I check this and is it to low at 900?

    Just with the USB cable connected and the APM armed, when I turn off the TX it disarms the APM. There is no GPS lock as this is indoors. Will this fail safe work without GPS lock if just flying in stabilize mode?

  • Congratulation developers,

    A job well done. Thank you very much for your time, effort and support.

    I had a go at 3.0.1rc2 at it worked great. Looking at the log I saw roll/pitch following rollin/pitchin with minor oscillations in STABILIZE. Reducing RATE_RLL_P and RATE_PIT_P got rid of the oscillations. After replacing the pink foam in that came with the APM case with black thicker foam I believe my random changes in altitude also went. ALT_HOLD, LOITER (now without wobble) and CIRCLE mode worked fine so I was confident enough for an AUTO mission. AUTO also worked fine but left me with a question on how to put in a mission command that does the same as CIRCLE mode. I tried LOITER_TURNS with 1 turn and a 0 in the altitude field. Reaching this command after aq waypoint in 60ft altitude the copter descended.I aborted 5 ft off the ground. Do I have to put in an altitude in the altitude field? I was under the impression 0 equals to current altitude.

    Can somebody please advise on how to use LOITER_TURNS and on how ROI works?

    Thanks,

    Michael

  • With the 3DR IV Sensor power module, does this supply enough power to the APM2.5 board so that the out put pins on A10 and A11 are sufficiently able to power the servos for the camera gimbal? Or do we still need to use a separate ubec to avoid brown outs?  I am using two small analog 9g servos.

    Also is this comment still relevant for the setting up the 3DR IV Sensor Power module?

    " You need to measure the voltage from the Power Module's regulator after the APM's diode and fuse, an easily accessible point to measure this is the fuse's lead highlighted in the image above. Type your measured voltage into the field labeled  1. APM Input voltage". 

    This area grays out and becomes not editable when selecting this power module so I assume this is not needed now?

    Lastly , I'm a bit confused between Throttle Accel and Throttle Rate and which one to set to get a firm hover. My hover tends to wanders up and down a bit and I have to constantly adjust the throttle and its difficult to find a throttle position where it maintains a stable hover position. . Note this is during flying indoors with no sonar and no GPS and only in stabilize mode. Ive not tried it outdoor yet. (broken leg has stopped play)

  • Excellent work on 3.0.1. It is amazing!  I use SimonK ESCs and I'm still getting some twitch and wandering in Loiter. It is significantly better than 3.0r1

    I'm new to ArduCopter (experience with ArduPlane). I'm not sure if it is a SimonK ESC issue or a configuration issue. I have done some RATE D and P tuning based on the instructions from DaveC.

    Here is my set up:

    F450 frame

    APM 2.5

    ArduCopter 3.0.1

    SimonK ESC 30A

    RCTimer 2830 - 1000KV motors

    Here are my PID settings. I did reduce Loiter PID P per warning #2.

    3692772674?profile=original

    Log files attached below.

    Any feedback is appreciated.

    3.0.1_simonK_loiter_text.zip

  • I have a weird problem: copter in loiter mode slowly climbs up. Barometer and GPS alts seems reflect the actual altitude, sonar is not even connected and is always 0m. At the plot below at 20 I switched into stabilize mode and brought the copter down a bit, then switched back to loiter.

    This is the original 3DR APM2.5 with F450 frame.

    3692772515?profile=original 

This reply was deleted.

Activity

DIY Robocars via Twitter
RT @a1k0n: Did I get rid of hand-tuned parameters? Yes. Am I still hand-tuning more parameters? Also yes. I have a few knobs to address the…
14 hours ago
DIY Robocars via Twitter
RT @a1k0n: I'm not going to spoil it, but (after charging the battery) this works way better than it has any right to. The car is now faste…
14 hours ago
DIY Robocars via Twitter
RT @a1k0n: Decided to just see what happens if I run the sim-trained neural net on the car, with some safety rails around max throttle slew…
20 hours ago
DIY Robocars via Twitter
Saturday
DIY Robocars via Twitter
RT @SmallpixelCar: @a1k0n @diyrobocars I learned from this. This is my speed profile. Looks like I am too conservative on the right side of…
Saturday
DIY Robocars via Twitter
RT @a1k0n: @SmallpixelCar @diyrobocars Dot color is speed; brighter is faster. Yeah, it has less room to explore in the tighter part, and t…
Saturday
DIY Robocars via Twitter
RT @a1k0n: I'm gonna try to do proper offline reinforcement learning for @diyrobocars and throw away all my manual parameter tuning for the…
Friday
DIY Robocars via Twitter
RT @circuitlaunch: DIY Robocars & Brazilian BBQ - Sat 10/1. Our track combines hairpin curves with an intersection for max danger. Take tha…
Thursday
DIY Robocars via Twitter
RT @SmallpixelCar: Had an great test today on @RAMS_RC_Club track. However the car starts to drift at 40mph. Some experts recommended to ch…
Sep 11
DIY Robocars via Twitter
RT @gclue_akira: 世界最速 チームtamiyaのaiカー https://t.co/1Qq2zOeftG
Sep 10
DIY Robocars via Twitter
RT @DanielChiaJH: Always a good time working on my @diyrobocars car at @circuitlaunch. Still got some work to do if I’m to beat @a1k0n howe…
Sep 10
DIY Robocars via Twitter
RT @SmallpixelCar: My new speed profile for @RAMS_RC_Club track https://t.co/RtLb7TcgIJ
Sep 10
DIY Robocars via Twitter
RT @SmallpixelCar: Practiced at @RAMS_RC_Club today with my new @ARRMARC car https://t.co/AEu2hCx89T
Aug 28
DIY Robocars via Twitter
Aug 24
DIY Robocars via Twitter
RT @gclue_akira: 柏の葉で走行させてるjetracerの中身 #instantNeRF #jetracer https://t.co/giVvuE4hP7
Jul 4
DIY Robocars via Twitter
Cool web-based self-driving simulator. Click save when the AI does the right thing https://github.com/pncsoares/self-driving-car
Jul 4
More…