ArduCopter-3.0.1 released!

ArduCopter 3.0.1 has been released and is now available in the Mission Planner,, GitHub and the new Downloads Area.

Warning #1: Compass calibration and reducing interference is far more important than with 2.9.1b

Warning #2: GPS glitches can cause sudden and aggressive position changes while in loiter mode.  You may wish to reduce the Loiter PID P to 0.5 (from 1.0) to reduce aggressiveness (see image below of where this gain can be found in mission planner).

Warning #3: optical flow is not supported but will be back in the next release (AC-3.0.2 or AC-3.1.0).

Warning #4: loiter turns does not maintain altitude.  This bug will be fixed in AC-3.0.2.

Warning #5: This release has only been lightly tested on Traditional Helicopters.

Improvements over 2.9.1b include:

  • Inertial Navigation for Loiter and Auto meaning much more accurate control (Randy,Leonard,JonathanC)
  • 3D navigation controller follows straight lines in all dimensions between waypoints (Leonard,Randy)

         WPNAV_SPEED, WPNAV_SPEED_UP, WPNAV_SPEED_DN, WPNAV_ACCEL allows configuring speeds and acceleration during missions

  • "compassmot" to compensate for interference on compass from the pdb, motors, ESCs and battery.  (Randy,JonathanC) (Set-up video here)
  • Safety improvements:
    • simple Tin Can shaped Geo Fence
    • pre-arm checks to ensure all calibration has been performed before arming (can be disabled by setting ARMING_CHECK to zero).  (video description here)
    • GPS failsafe - switches to LAND if GPS is lost for 5 seconds
    • stability patch improvements to stop rapid climbs in very overpowered or overtuned copters
  • Circle mode improvements including "panorama" when CIRCLE_RADIUS set to zero (Randy,Leonard)
  • SONAR_GAIN parameter added to allow better tuning of sonar surface tracking
  • CH8 auxiliary switch (same features as CH7)
  • works on PX4 (some minor features still not available) (Tridge,PatH)

How to upgrade:

1. Make sure you are using Mission Planner 1.2.59 or newer (get it here)

2. Click on the MissionPlanner's Hardware, Install Firmware screen.  The version numbers should appear as "ArduCopter-3.0.1", then click the appropriate frame icon and it should upgrade as per usual.

3. Reduce the Loiter and Alt Hold PIDs if you have modified them from the defaults.  The modified PID values for the 3DR frame can be seen in the image below.

Note: Nav parameters have been combined with Loiter so do not be concerned if you can't find them.


4. Although not directly related to this release, if you purchased an APM prior to March of 2013, update your PPM encoder to the latest firmware (instructions here).

5. Try out the new version in stabilize mode first, then alt-hold, then loiter and finally RTL and Auto.

Numerous How-To videos are available:

Special Thanks to MarcoDaveC and the large number of testers on the pre-release thread who put their copters at risk during the extended testing period.  Some of their videos can be found hereherehereherehere and here.  Thanks also to MichaelO for the MP changes required for this release.

All feedback welcome.  Please put your questions, comments (good and bad!) below.

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • Thanks for the hard work. Looking forward to the optical flow in 3.02

  •  I had two motors the wrong way around so all good now. How can I see where the vibration readings are?

    2013-07-14 11-19-00.tlog

  • WOW! I used to have to spend hours playing with PIDs. With this release I'm using the default PIDs and it's never been that good! I tested stabilize, alt-hold, RTL, missions, circle, flying in loiter... all in windy cinditions! The quad is super stable even in these windy conditions. Today I flew in conditions that I would not have been able to fly in before! Excellent!

    Thank you


    Stock DJI F450, 5000 mah 3c, 10x4.5 DJI props (motors and props balanced)

  • 3.0.1 is great! what a difference. It is perfectly stable on my ArduCopter Quad. I really appreciate the work contributed by all the people working on this project. 

    I am now ready to put my gimble on and and start using it for my photography hobby.

    I do have one thing that I can't figure out....  I can't arm it from my radio for some reason. I hold the left stick to the bottom right corner and it just doesn't arm.     I have to arm it from MP. I did all the steps of calibrating the radio and checking the failsafe and all looks correct.

    Once armed using Mission Planner, all is fine.   any ideas what could prevent the arming from the radio, yet let mission planner arm it?

  • Randy,

    The altitude hold problem I was seeing yesterday (from other thread) seems to have gone away.  which is good but I hate not knowing why.

    The only changes I made were to put the rubber bands holding the apm back which meant I had to remove the power module, when I put it back it is in a slightly different place. I also enabled the default logs (plus IMU). the other change is it was quite a bit more humid the last 2 days.

    I was thinking because this is my first hexa I noticed the wind effects it a lot more than the quads and maybe it was the wind causing the altitude change in loiter (loiter holding it, the wind can only take it up or down??)  I have seen this in the past, where althold works well but then  wind will cause the copter to loose or gain alt. Is THR_ALT_I the correct PID to help with this?

    So, after 2 days of trying to fix althold problems, I dont know, it did very well today with really no changes, locked on to 15 sats which is a record for me:)

    I have been disabling most or all of my data flash logs (unless I am having a problem) to lighten processing load, is this ok? or are there any logs that should always be enabled?

    thanks for your help


  • I will probably embarrass myself with this post......but what the heck am I doing wrong?  Or do I just have a bad GPS (ublox)? See attached log - running 3.0.1

    2013-07-13 16-46-32.tlog

  • Congratulation !Great release! very stable and fun !

    but a a strange thing happens, every time motor start lost connection with pc ( i use xbee900)

    and when stop it is regularly reconnected ?!?

    up to version 3.0.0 rc6 work fine , how it change?

  • Hey All,

    I've been following this thread and the previous "3.0-ready for wider use"  with great interest.  I've had minor problems that I've waited out for the release of 3.0.1, but this morning had a crash that I can't explain....I took advantage of a rare windless morning to test out 3.0.1 and had a really enjoyable FPV flight and a successful alt hold and then short loiter at the end of the flight (log 33 attached).  Encouraged, I hooked up the next set of batteries but unfortunately the next flight was short and not successful (except for a brilliant perfectly vertical take off).  This flight is log 34 attached.  I looked at the logs a bit and don't think there was a hardware failure, but I could be wrong given I'm new to trying to analyze logs.  Randy or someone else could you take a look at the logs please, and let me know if anything that caused the crash jumps out at you?  Otherwise do things look okay?

    I've isolated vibration to the APM fairly well I think (orange ear plug method, with radio rx and wires velcroed to the top of the APM for further isolation and mass dampening).  I've run compassmot and modified APM mounting as much as I can to reduce interference.  Balanced props and motors, etc.  More on my setup:

    -Custombuilt quad X 600mm dia

    -Motors: 2220/07 1200kv with APC 10X3.8 props

    -30A ESCs (no SimonK firmware)

    -4400 to 5800 mah 3S

    -running DroidPlanner with telemetry while in flight to confirm flight mode and get battery reports.

    2013-07-13 10-01 34.log

    2013-07-13 10-00 33.log

  • I've just uploaded this release, flew it a bit on my tricopter, and it is super rock solid.

    Stabilize, Loiter, ALT Hold,and RTL work flawlessly. 

    I haven't tested the auto-mission. 

    Once again, I commend all members in the development team. Thank You!

  • Hello everyone! Sorry my english.
    Most of the work is done in 3.0.1!

    If something has changed in the behavior of RTL in the mission compared to 2.9.1b?
    I usually make a mission with Takeoff, then fly to waypoints and RTL on last waypoint. Previously, before flying home machine turned his nose and flew, then landed. And now turns when the RTL strange. Tried to switch modes of behavior, but did not get a good result.

This reply was deleted.