ArduCopter-3.0.1 released!

ArduCopter 3.0.1 has been released and is now available in the Mission Planner,, GitHub and the new Downloads Area.

Warning #1: Compass calibration and reducing interference is far more important than with 2.9.1b

Warning #2: GPS glitches can cause sudden and aggressive position changes while in loiter mode.  You may wish to reduce the Loiter PID P to 0.5 (from 1.0) to reduce aggressiveness (see image below of where this gain can be found in mission planner).

Warning #3: optical flow is not supported but will be back in the next release (AC-3.0.2 or AC-3.1.0).

Warning #4: loiter turns does not maintain altitude.  This bug will be fixed in AC-3.0.2.

Warning #5: This release has only been lightly tested on Traditional Helicopters.

Improvements over 2.9.1b include:

  • Inertial Navigation for Loiter and Auto meaning much more accurate control (Randy,Leonard,JonathanC)
  • 3D navigation controller follows straight lines in all dimensions between waypoints (Leonard,Randy)

         WPNAV_SPEED, WPNAV_SPEED_UP, WPNAV_SPEED_DN, WPNAV_ACCEL allows configuring speeds and acceleration during missions

  • "compassmot" to compensate for interference on compass from the pdb, motors, ESCs and battery.  (Randy,JonathanC) (Set-up video here)
  • Safety improvements:
    • simple Tin Can shaped Geo Fence
    • pre-arm checks to ensure all calibration has been performed before arming (can be disabled by setting ARMING_CHECK to zero).  (video description here)
    • GPS failsafe - switches to LAND if GPS is lost for 5 seconds
    • stability patch improvements to stop rapid climbs in very overpowered or overtuned copters
  • Circle mode improvements including "panorama" when CIRCLE_RADIUS set to zero (Randy,Leonard)
  • SONAR_GAIN parameter added to allow better tuning of sonar surface tracking
  • CH8 auxiliary switch (same features as CH7)
  • works on PX4 (some minor features still not available) (Tridge,PatH)

How to upgrade:

1. Make sure you are using Mission Planner 1.2.59 or newer (get it here)

2. Click on the MissionPlanner's Hardware, Install Firmware screen.  The version numbers should appear as "ArduCopter-3.0.1", then click the appropriate frame icon and it should upgrade as per usual.

3. Reduce the Loiter and Alt Hold PIDs if you have modified them from the defaults.  The modified PID values for the 3DR frame can be seen in the image below.

Note: Nav parameters have been combined with Loiter so do not be concerned if you can't find them.


4. Although not directly related to this release, if you purchased an APM prior to March of 2013, update your PPM encoder to the latest firmware (instructions here).

5. Try out the new version in stabilize mode first, then alt-hold, then loiter and finally RTL and Auto.

Numerous How-To videos are available:

Special Thanks to MarcoDaveC and the large number of testers on the pre-release thread who put their copters at risk during the extended testing period.  Some of their videos can be found hereherehereherehere and here.  Thanks also to MichaelO for the MP changes required for this release.

All feedback welcome.  Please put your questions, comments (good and bad!) below.

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • I have a TBS Discovery quadcopter that I just installed the APM2.5 in.  I'm running V3.0.1 and Mission Planner 1.2.60 mav 1.

    I initially had trouble getting the "Loiter" working (really bad toilet bowling), however, I spent a lot of time performing compass and compassmot calibrations to make sure they were consistent and now it loiters unbelievably well.  The RTL function also works flawlessly. So, now I have moved on to testing flight missions with the takeoff, waypoint, condition and landing commands and herein is my problem.  Auto takeoff and landing functions work well and it flys to waypoints .... but .... I cannot get the Condition Yaw or Condition Delay commands to work.  These commands appear to be ignored and the quadcopter immediately proceeds to the next waypoint in the sequence.  Shown below is one of the planned missions I have tried that ignores the Condition Yaw command (all other commands are executed perfectly).  I have tried various values in the parameter fields which include different angles in both relative and absolute modes as well as different time values over which to perform the maneuver.  Same goes for the Condition Delay command.

    I can't help but think I'm doing something stupid because all the other commands work.  I also installed Qgroundcontrol and used it to read in the commands that I put on the APM2.5 using Mission Planner.  Everything look as it should and it shows a "115" code value for the Condition Yaw command.

    Help !  Anybody have any idea what is happening here ?




  • re. Sonar

    Hello Olivier,

    the result in my test setup varies between 40cm and 130 cm. The sonar is exactly 100 cm away from a wall.
    It is the same at the copter, the signal fluctuations are very high.

    I have built a highly accurate DC voltage source, shielded cables and the R / C filter.

    I have all the available types of MaxBotix here, all behavior is equally bad.

    In my copter the sonar is mounted in the bottom center, exactly in the right place.

    A horn I have not tried it yet. That would be a possibility, but I do not mind.

    regards Peter

  • Okay I'll ask this because looking back I haven't seen it asked (at least I didn't see it anyway) using 3.01 RC 1 when flying mission or return to launch the copter isn't turning and pointing towards the waypoint or home location for some reason. This is something that needs to be set in mission planner now?

    I ran all the hardware configurations including compassmot and flight, altitude hold, loiter return to launch, auto landing everything worked perfectly out of 2 flights the 1st landing was maybe 3 feet to the left of where the actual liftoff was and the 2nd flight was absolutely perfect landing exactly where it took off on a concrete pad. The only thing I can see is that it's not turning and facing the new way point or turning and facing the home position when return to launch.

  • A little FPV with 3.0.1, works really well with my F450. This is a raw video taken from a key chain camera velcroed to the bottom of the quad.

    - very hot morning (thermals)

    - start with a 360 in loiter, stabilize flying, RTL at the end.


  • Hi Randy,

    Will it not be possible to get a comment for my post which is located here?

    I know you are busy but I would like to hear a few things from you. Like why my motors stopped?


  • I wonder which firmware version they used for this flight? :-D

  • Does anyone know what causes the spikes in the sonar ? What is the source of the pulsing "sudden" noise that causes the spike.

    Im guessing is it an overflow of some sort ?

    Funny thing is sonar seems to work without the crazy drop and restore if im really close to the ground say 1ish M. The more i lift the more dramatic the spikes.

  • Probable bug:

    it is been seen when activated RTL on MP. Manifested today 3 times (same lipo-pack), 1-2sec upon triggering RTL on MP (with do_action btn.), as litely agressivness with yaw-right for quarter the circle (0.3-0.5sec), then continued safely to home. Light windy day, stable conditions.

    Still expecting ROI to see, so Dev-Team go for it!

  • First of all: thanks for a great job!

    I flew my FPVManual with tMotors 3110 780kv around the other day and all worked great, but after switching from stab to loiter and back a few times, loiter became from perfect to more and more bonkers and the quad started to fly in big circles with wobbles, hard to keep level too and seemed pretty uncontrollable. I went back to stab, perfect, back to loiter: wobbles and circles. Landed, powered off and on and now stab and loiter where both ok, switched a few times but ran out of battery and time before I could make sure the effect was gone or still there. Did calibrate compass at different location, but tested compass next to iPhone compass with Missionplanner and saw that both iPhone and APM saw north as north in the same direction, so I assume that went ok. Any ideas? or just a bad boot?

  • Hm, so I had a successfull first flight with my apm2.5, mtk v2 gps and rctimer 450 clone kit today. I have added some pics of my setup since I think I get rather good compassmoot values (22%). I have also added my .log file since I have trouble deciding if my vibration levels look ok or not? (Is this the right log file to upload btw?)

    (my "antivibration setup": plastic plate <-> glue <-> dubro foam <-> glue <-> silver tape <-> apm).


    2013-07-16 22-35 4.log

This reply was deleted.


Neville Rodrigues liked Neville Rodrigues's profile
Jun 30
Santiago Perez liked Santiago Perez's profile
Jun 21