Developer

ArduCopter-3.0 ready for wider use

ArduCopter 3.0 is ready for widespread use.  To make the transition easier, this time we are asking people to voluntarily upgrade from 2.9.1b for the next month or so before we make 3.0 the default firmware downloaded by the mission planner.  The new version can be found in the Mission Planner's Beta firmware's link, firmware.diydrones.com, GitHub and the new Downloads Area.

Warning #1: A bug was found in the FENCE in which if you lost GPS it could lean at extreme angles as it tried to maintain an invalid position.  This is fixed in AC3.0.1-rc1.

Warning #2: This release has not been fully tested on Traditional Helicopters

Warning #3: GPS glitches can cause sudden and aggressive position changes while in loiter mode.  You may wish to reduce the WPNAV_ACCEL to 100 and Loiter PID to 0.2 (from 1.0) to reduce aggressiveness.

Improvements over 2.9.1b include:

  • Inertial Navigation for Loiter and Auto meaning much more accurate control (Randy,Leonard,JonathanC)
  • 3D navigation controller follows straight lines in all dimensions between waypoints (Leonard,Randy)

         WPNAV_SPEED, WPNAV_SPEED_UP, WPNAV_SPEED_DN, WPNAV_ACCEL allows configuring speeds and acceleration during missions

  • "compassmot" to compensate for interference on compass from the pdb, motors, ESCs and battery.  (Randy,JonathanC) (Set-up video here)
  • Safety improvements:
    • simple Tin Can shaped Geo Fence
    • pre-arm checks to ensure all calibration has been performed before arming (can be disabled by setting ARMING_CHECK to zero).  (video description here)
    • GPS failsafe - switches to LAND if GPS is lost for 5 seconds
    • stability patch improvements to stop rapid climbs in very overpowered or overtuned copters
  • Circle mode improvements including "panorama" when CIRCLE_RADIUS set to zero (Randy,Leonard)
  • SONAR_GAIN parameter added to allow better tuning of sonar surface tracking
  • CH8 auxiliary switch (same features as CH7)
  • works on PX4 (some minor features still not available) (Tridge,PatH)

How to upgrade:

1. Make sure you are using Mission Planner 1.2.59 or newer.

http://ardupilot.com/downloads/?did=63

2. Click on the MissionPlanner's Firmware screen and click the "Beta Firmwares" link on the bottom right.  The version numbers should update to "ArduCopter-3.0.1rc2", then click the appropriate frame icon and it should upgrade as per usual.

3691031698?profile=original3. Reduce the Loiter and Alt Hold PIDs if you have modified them from the defaults.  The modified PID values for the 3dr frame can be seen in the image below.

Note: Nav parameters have been combined with Loiter so do not be concerned if you can't find them.

3691032069?profile=original

3691032034?profile=original

4. If you purchased an APM prior to March of 2013, update your PPM encoder to the latest firmware.

http://copter.ardupilot.com/wiki/common-ppm-encoder/

http://copter.ardupilot.com/wiki/common-ppm-encoder-apm2x-atmega32u2/

5. Try out the new version in stabilize mode first, then alt-hold, then loiter and finally RTL and Auto.

Special Thanks to MarcoDaveC and the rest of the beta testers for putting their copters at risk during the extended testing period.  Some of their videos can be found hereherehereherehere and here.  Thanks also to MichaelO for the MP changes required for this release.

All feedback welcome.  Please put your questions, comments (good and bad!) below.  

Added by Craig:

Please watch Randy's videos on setting up and flying APM-Copter 3.0 before you go flying.  They are excellent!

3DR Quad Set-Up Suggestions        http://www.youtube.com/watch?v=33Tl_rjhQEE
AC 3.0 "Live" Compass Calibration  http://www.youtube.com/watch?v=DmsueBS0J3E
AC 3.0 CompassMot Setup                http://www.youtube.com/watch?v=0vZoPZjqMI4
AC 3.0 Pre-Arm Checks                      http://www.youtube.com/watch?v=gZ3H2eLmStI
AC 3.0 Fence                                         https://www.youtube.com/watch?v=HDnGdo54o-4
AC 3.0 Maiden Flight Checks             http://www.youtube.com/watch?v=NOQPrTdrQJM

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • Loaded 3.0.1-rc1 and setup as Randy's instructions last night. Got 3 test flights tonight and I am really impressed ALT Hold is solid and Loiter is impressive even in a gusty 10-15 mph wind.

    I have included a log of my last flight and would appreciate some tuning advice.

    I have a 3DR Hex with 800kv motors and 10 x 4.7 APC Props

    In Stabilise mode needs some tuning

    Loiter mode I notice it is making small sharp corrections

    RTL mode it climbs to the assigned altitude then suddenly aggressively starts al flies to home, above home stops aggressively then decends and lands as programmed.

     

    Thanks

     

    David Ardis

    2013-07-03 21-21 3.log

    https://storage.ning.com/topology/rest/1.0/file/get/3692763630?profile=original
  • Hi all,

    My setup:

    - APM2.5

    - Arducopter V3.0

    - NO Power Module

    - Mission Planner 1.2.58

    Problem: Can't access CLI in MP and can't run compassmot command.

    3692762783?profile=original

    I proceed as described in following video (except step #3 -no PM-),

    https://www.youtube.com/watch?v=0vZoPZjqMI4

    I tried with two different computers (XP and Win7)

    I do something wrong? Any ideas?

    Thanks.

  • Noticed a problem. When I load a mission planner 1.2.58 file with the flight. Tlog, when you play the mission mode continuously shows "unknown". Instead RTl, Auto, Loiter ... Please correct

  • Hi Randy,

    I flew the v3.0.0 last week for the first time but didn't get a chance to post my log. Could you please look and tell me if my vibration level is okay?

    It was a short flight; I only used stablize and Loiter (maybe Acro as well) modes.

    My compassmot calibration was a disaster. I got 469%!!! but flew the copter anyways because it was always like that and was flying fine. I am using F450 frame with the stock setup; 4s pack 8" props.

    Thanks

    2013-06-25 18-09 1.log

  • After a couple of hours of perfect, event free 3.0 flight I finally had a crash.   My 3DR Hex flew great.   All modes worked as they should.  It was a pleasure to fly.

    Today I applied a bit more isolation to the 'stack' holding the APM.  I added rubber spacers.  But that's all I did.  It's the only change I made  (And I don't know why I did it since everything was running great).

    I was about 6 minutes into the flight.  I was trying a bit of 'loiter flying' when it suddenly dropped out of the air.  It was flying and the it just fell. There was no warning.  Fortunately it didn't fall far and the damage was minimal.

    I've looked at my logs, but can't see anything that might have caused the crash.   I'd appreciate if a more trained eye could take a peek.  

    2013-07-02 12-07 8.log

    2013-07-02_11-26-24.tlog

    https://storage.ning.com/topology/rest/1.0/file/get/3692762058?profile=original
  • I've been using Arducopter 3.0 for several flights, and it's also very nice in hard conditions (big speed, tight turn, flip, ...).
    I have some GPS glitch problem and a strange behavior even with WPNAV_ACCEL to 100 and Loiter PID to 0.2.
    Usually after powering my copter I wait to get 7 to 8 satellites before taking off. If after take off I put my copter in Alt Hold, it's nice, but if I put my copter in LOITER after 2s or 3s, my copter suddenly goes away, so no problem to regain control but strange behavior.
    This strange behavior seems to occurs only after take off.
    A thing that could be handy, is to use telemetry port (or any other serial port) instead of USB to get logs, because most of the time plugging the USB cable into the APM is a little hard and the board could move, so level may not be the same after.
    Is there any reason why log can't be downloaded with another serial port than USB ?

    Thanks,

  • Hello

    I have been using 3.0-rc1since it's available with pretty good results (Stab,Alt_hold,loiter & RTL).

    Yesterday while in Loiter the quadri went wild ,and I could 't controlled it ,the bird finished against a tree !!!

    I am very lucky only minor damage ( Landing gear ,props).I am well aware of the warning # 3.

    I just wonder if this is a GPS glitch  ?

    Here is the flog for this flight.

    Thanks for your opinion.

    2013-07-01 19-34-52.tlog

  • Hi 

    I have just upgraded to Mission Planner 1.2.58 and set about upgrading my apm 2.5 to AC3.0.1-rc1.

    Two problems to fix:

    1. Logs are no longer being created. Terminal Mode no longer works properly - displays an error in Terminal.cs line 415

    2. In Alt_Hold mode, the quad 'hunts'.

  • I moved the onboard compass on my APM1 board up about 5cm and now I get the following offsets: -190 -602 895

    I did it twice and both times I got such high values on the Y and Z axis.  Could it be that I damaged the compass during the move?

    My CompassMot value has however gone down from 54% to 10%... :-)

  • I am somehow confused when it comes to the magfield influence by the electrical components as such.

    I have several copters and when looking to one (warthox-frame) which has excellent loiter the graph shows quite clearly that the throttle has impact to the magfield. throttle seems to decrease the magfield vector there:

    3692760399?profile=original

    here I am still on the internal compass, since it works fine for me. note, that this copter has a power distribution board and the battery is centered on the bottom of the copter. so everything is pretty symmetric on that quad.

    in contrast to that another frame (q40) goes into TBE quite immediatly when entering into loiter mode. here the magfield looks not impressed that much by throttle. this frame is smaller than the good working warthox frame above, has a spider-shape and the battery is more in the rear bottom. so in general that one is not symmetric when comparing front to rear.

    in the beginning i started with the integrated compass and TBE was pretty strong. the graph looked similar like from the good working warthox frame, however, magfield was influenced in completly opposite direction, i.e. meaning throttle did increase the magfield vector:

    3692760751?profile=original

    next i moved to external compass which points out on the graphs pretty good, still some influence visible, but much less compared to before. problem is, that this guy still goes into TBE:

    3692760666?profile=original

    Now I am somehow confused how to interprete the magfield graph correct, since it shows the complete opposite from what i expected.

    next point is that i will move the compass even more far away from the frame. (from currently 40mm to 100mm).

    can please someone have a look to my diagrams/tlogs and explain me how to interprete the graphs correctly?

    thanks a lot and best regards from vienna!

    Christian

    tlog.zip

This reply was deleted.

Activity

Santiago Perez liked Santiago Perez's profile
yesterday
More…