Developer

PixRacer with Ardupilot

This is a discussion to focus the feedback and support of ardupilot on the PixRacer board from AUAV.co.

We believe that all teething problems encountered are now resolved and so we recommend people load Copter-3.3.4 which is available for all multicopters through the Mission Planner's (and other GCS's) Install Firmware screens.  Note that because regular Pixhawks are still on Copter-3.3.3 the install icon may show Copter-3.3.3 but rest assured, Copter-3.3.4 will be installed (you can check the version by looking at the very top of the Mission Planner).

3691274249?profile=original

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

      • I've got 1.3.37 build 1.1.5932.22903 like yours. I normally click on Help/Check for BETA Updates every other day.

        Just to make sure it is not Pixracer's fault I just tried to upload APM via MP to an AUAV-X2 board. Not working either. So maybe a MP issue? Nothing changed on my laptop, which was used a week ago to flash the AUAV-X2 and a 3dr pixhawk.

        I just managed to upload the APM flight stack (3.4dev from http://firmware.ardupilot.org/Copter/2016-03/2016-03-30-08:03/PX4-q...) via QGroundControl. So all good. Connecting to MP for configuration after the flashing works fine.

        • Did you already fly the 2016-03-30 build?

          Want to flash a 3.4 dev-version but I want to make sure that its safe to fly first ;)

        • I have the same problem with my PixRacer. So far used QGroundControl to flash APM. There is a special option for that. Still playing with everything on the bench. Have GPS/radio working, but cannot make APM to read correct voltage/current from  ACP4.

  • IS THIS THE SAME BOARD or a different one

    5024_dimg4.jpg?width=500

  • Same problem for me with px4, none of the standard frames worked at all, no possibility to put PID on poti, no autotune, what good is a firmware in which all things like rssi, FRSky telemetry etc work, but you can only be happy about these functions while grounded? I prefer firmware my quad can fly with...

    Versions i used without any memory issues at all: master from 19.03.2016 and 26.03.2016 (used others, but those are the only copys i did not overwrite).
    Is it possible, that you installed Beta from MP instead of Master?

    I am quite sure that the memory bug disappeared from master for at least a month.

    Master installation: download file "ArduCopter-v4.px4" from here : http://firmware.ardupilot.org/Copter/2016-03/2016-03-29-07:03/PX4-q...

    For older versions just click "parent folder" on top and then select the date

    Then in MP select "Load custom firmware", done.

  • As written some time ago i didn't get rssi to work with the rssi-in pin of the pixracer. Neither with direct connection to Frsky Rx nor with normalized voltage.
    Only way i got it working was by programming the Taranis to output rssi on channel 16 and installing master Version of copter (stable version doesn't have the option "rssi via pwm") on pixracer. Except vertical variance errors and uncommanded yaw for ~1 minute after arming i have no problems with master, after the first minute it works perfect.
    I got my board in January, so I am quite sure its not the newer r14 version, so are you really sure you got it working via analog input on your pixracer?
    • I guess I am not sure...   So probably safe to assume it was never working..
      I was working on a non-pixracer copter last month for a friend, and I guess I am getting them mixed up....

      I'll try master!  (unfortunately it JUST started raining :(  )

      • Well..... Tried master..  I can get RSSI working there.. 
        BUT..  It has the memory issue from a month ago!  So, I can calibrate it, it saves, I reboot, I get bad gyro, and all the settings are lost.  I compare and upload params.. Sometimes it takes it.. Other times it resets everything.    It is the exact same problem that was solved a month ago... but it's back in master, I guess.

        Is there a way to download specific builds of master, rather than the most recent? I'll figure out what Azd2 is running, and use it..  I really really really want to finally fly this thing, after 2 months of tinkering and waiting for code to be up to par....  PX4 is not an option... it doesn't work w/ my OSD, and it just doesn't fly well.....   APM works perfectly except RSSI.. Or in master, this memory issue....

  • RC14 are the R14 PCBs. The C denotes the PCB supplier. I doubt RSSI is enabled in either firmware. I will investigate and report back tomorrow. As for the circuitry, they do not differ on this IO pin. The only difference, is with R14, we have greater authority to bring the RC input line to 0. I will work on getting the schematics published shortly.
This reply was deleted.

Activity

Santiago Perez liked Santiago Perez's profile
Saturday
More…