ArduCopter cannot fly anyway


I'm going crazy about watching people's quadcopter videos and failing to build my own with most expensive devices and breaking and re-purchasing everything!

Please tell me what I'm doing wrong.

Motors: Dualsky Xmotor 3542CA-6 450W 940Kv       (4x same motors)
Propeller: 12x4.5 (4x puller and pusher set)
Flight controller: ArduPilotMega 1.4 (with 2560 processor)
IMU oilpan shield included (attached to APM)

APM software version: Latest (updated yesterday)
In Mission Planner, RC calibrated. (moved stickers to max of each side)
Frame is +

ESCs calibrated using auto mode (all ESCs at once)
Frame: I created it myself, 2 types, wooden and from aluminum. Both is stable and had no diff for me.

Battery: 30C 3800mah 11.1V (2x, attached to my power board, both connected to power board as power input and I use them together, so infact it's like I'm having 7200mah)

Please advice. What's wrong? My battery is not enough for my motors?
I can't fly using these propellers?
I can't  fly using these motors?
I can't fly using this batteries?
I can't fly using APM?

Everything I saw in internet, I tried. None worked! Please help me, please!
My QuadCopter always flips over two legs and just crashes blades, simply! As soon as I start to spin motors, two motors are always or sometimes three motors rotates faster than others and therefore it tries to takeoff via two legs and simply it crashed to ground and breaks blades. It always rotates around itself, some motors spins faster and it always crashes and breaks.

Please advice
Please help

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • Sounds to me you connected the motors wrong to the APM. I had similar problem, did not realize that the APM has a front side and it should be inline with your quadcopters front, I connected the left side motors on the right side. So when the copter tilts a bit on lift up, the APM tries to correct it, but only worsen the tilt because its spinning the wrong side faster, causing it to flip.

  • As you say your motors spin faster than others, it doesn't need to be the controller. Sure it can, but it can also be other causes. At some point when calibrated the ESC 5 times, everything is tried to be reconfigured, and still not even close to get it not spinning around its own axis, I would look at the hw.

    Something can be faulty (or loose) as well. Ardupilot have always causing no trouble at all for me. Once I had a problem with a multiwii based quad, but it wasn't the controller. It was behaving like you describe yours. I know the feeling you got.

    It was spinning around its own axis, flipping around and just going crazy when giving some throttle. I tried changing ESCs, but ended up replacing a couple of motors, and In my case i found out motorwindings was broken. Probable damage in a "hard" landing.When all ESC where replaced, I realized it had to be the motors, and when lookin at them, I could actually see that two where behaving different than the others. First I could see one of them behaving different, i replaced that one. Then there was another one that didn't behave like the other tree. After that replacement It worked like a charm.

    You have to exclude possible problem causes, divide and conquer, otherwise you won't find your problem. Regular troubleshooting. 

  • Are the props on up side down?  check the writing on the blades.

    Also make sure your radio trims are 0.

    On my quad just today it was tilting about 30 degrees forward on take off.  I tried looking at all the settings on my radio and connected to my computer and test the motor output (without the blades) and all motor outputs were level.  What I did to fix the problem was to use the erase command in the CLI setup screen.  One of my issues I have notice if I try using inputs 7 and 8 it some times screws with the settings.  I think is something to do with auto trim but not sure.

  • Don't know, but I think my entire problem is PID settings.

    How can I find proper PID settings for my frame/motor/esc?


  • Developer

    I had the exact same problem . I had not done the "level" correctly.

    When you are connected to mission planner and it is on a table or floor, is the horizon in MP level? or does it show a tilted horizon?

    Re-do everything in the instructions, line by line I'm afraid...

  • Here is quite safe way to test copter: old matress. Then I tied a short line to the middle of copter, and other side through a matress, and there to a wooden stick.

    I can freely test copter, motors and everything. In this picture copter is flying at a 15 cm altitude.  That is enough to make almost all preliminary tests. It is impossible to break copter!


  • This kind of issue sounds typical of having the board oriented incorrectly.  Verify that the board is around the right way, and you have each motor plugged into the right port.

  • you list yourself as NY, NY I work in paterson NJ maybe we can meet up so someone can get a hands on look at whats going on.

    let me know if you can get out that way during the week.

  • You are using + configuration.  Did you  set it to + ?  I believe the default is X.

    Also, if using plus, it the APM pointing to motor #3?  Is #3 CW?

  • Have you done step 5 in

    Let follow this step to level your quad.

    Anyway, post your quad pics for more details.

This reply was deleted.