Developer

ArduCopter-3.0.1 released!

ArduCopter 3.0.1 has been released and is now available in the Mission Planner, firmware.diydrones.com, GitHub and the new Downloads Area.

Warning #1: Compass calibration and reducing interference is far more important than with 2.9.1b

Warning #2: GPS glitches can cause sudden and aggressive position changes while in loiter mode.  You may wish to reduce the Loiter PID P to 0.5 (from 1.0) to reduce aggressiveness (see image below of where this gain can be found in mission planner).

Warning #3: optical flow is not supported but will be back in the next release (AC-3.0.2 or AC-3.1.0).

Warning #4: loiter turns does not maintain altitude.  This bug will be fixed in AC-3.0.2.

Warning #5: This release has only been lightly tested on Traditional Helicopters.

Improvements over 2.9.1b include:

  • Inertial Navigation for Loiter and Auto meaning much more accurate control (Randy,Leonard,JonathanC)
  • 3D navigation controller follows straight lines in all dimensions between waypoints (Leonard,Randy)

         WPNAV_SPEED, WPNAV_SPEED_UP, WPNAV_SPEED_DN, WPNAV_ACCEL allows configuring speeds and acceleration during missions

  • "compassmot" to compensate for interference on compass from the pdb, motors, ESCs and battery.  (Randy,JonathanC) (Set-up video here)
  • Safety improvements:
    • simple Tin Can shaped Geo Fence
    • pre-arm checks to ensure all calibration has been performed before arming (can be disabled by setting ARMING_CHECK to zero).  (video description here)
    • GPS failsafe - switches to LAND if GPS is lost for 5 seconds
    • stability patch improvements to stop rapid climbs in very overpowered or overtuned copters
  • Circle mode improvements including "panorama" when CIRCLE_RADIUS set to zero (Randy,Leonard)
  • SONAR_GAIN parameter added to allow better tuning of sonar surface tracking
  • CH8 auxiliary switch (same features as CH7)
  • works on PX4 (some minor features still not available) (Tridge,PatH)

How to upgrade:

1. Make sure you are using Mission Planner 1.2.59 or newer (get it here)

2. Click on the MissionPlanner's Hardware, Install Firmware screen.  The version numbers should appear as "ArduCopter-3.0.1", then click the appropriate frame icon and it should upgrade as per usual.

3. Reduce the Loiter and Alt Hold PIDs if you have modified them from the defaults.  The modified PID values for the 3DR frame can be seen in the image below.

Note: Nav parameters have been combined with Loiter so do not be concerned if you can't find them.

3691038784?profile=original

4. Although not directly related to this release, if you purchased an APM prior to March of 2013, update your PPM encoder to the latest firmware (instructions here).

5. Try out the new version in stabilize mode first, then alt-hold, then loiter and finally RTL and Auto.

Numerous How-To videos are available:

Special Thanks to MarcoDaveC and the large number of testers on the pre-release thread who put their copters at risk during the extended testing period.  Some of their videos can be found hereherehereherehere and here.  Thanks also to MichaelO for the MP changes required for this release.

All feedback welcome.  Please put your questions, comments (good and bad!) below.

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • MR60

    I get following roll In/roll graph :I notice Roll follows Roll in with a bump in negative (-Y). Does this mean a too low PID setting ? (I have Rate Roll/Pitch and I=0.12 and D=0.04 but for an X8 weighing a good 9 pounds and 12x3,8 props =>probably too low values, although I use it for photography so I want a rather smooth X8, not a race track one). Anybody can comment on that ?:

    3692783175?profile=original

     

    I then get this graph for THrIn, Thr where I notice Thr out gets bumpy at certain moments in the graph (i remember I turn on Alt Hold at a certain moment, would that explain this Thr Out not following Thr In perfectly ?):

    3692782974?profile=original

     

  • Problem: GPS(UBLOX-6H) fails to lock position when using fireware APM3.01 in loiter mode

    My GPS(UBLOX-6H) fails to lock position when using fireware APM3.01 in loiter mode, but everything is OK when using fireware APM2.91b in loiter mode.

    When using my GPS with both APM3.01 and APM2.91b, Mission planner shows the right longitude and latitude, also shows 3DFIX and SAT NUM. The longitude and latitude ripples in acceptable range.

    After switching to loiter mode(APM3.01), the frame begins shaking, then flying towards an arbitrary direction quickly.

  • I posted about this in another thread, but this seems a more appropriate place.  I'm running 3.0.1 and having issues with loiter.  In stabilize and alt-hold the hexa performs pretty well.  Once I put it into loiter mode it starts to slowly pitch in one direction.  This pitch begins to become more and more pronounced until I take it out of loiter mode.  I initially thought it was due to a compassmos problem.  I was somewhere near 180%. I installed an external compass and lowered it to 6%.  The issue remained. 

    While looking at my logs I've noticed two things that are odd to me.  First under NTUN the WPdst is always 1.95cm while in loiter mode.  This never changes.  The Hdop is at 3.01.  So, my guess is for some reason the WPdst does not get updated and the drone keeps pitching in the desired direction trying to get closer to the WP, but fails.  This causes the drone to pitch more and more until I take it out of loiter. 


    Any idea why WPdst is not changing?

    I uploaded my logs to this thread, but for some reason I'm getting "Access Denied" when I try to download them now.  They are on a different computer and I won't be able to repost them until later today.

    http://diydrones.com/forum/topics/apm-drifts-in-loiter-position-hol...

  • Further more, tried MP 1.2.53

    Started with the working external compass, then did a hot swap testing the 2 not working, (se above) and the now show OK in the HUD, strange?

  • Hi, I have some questions regarding externall compass.

    I have APM2,5 from RCtimer

    3 HMC5883L board, 2 of them report "compass init error"

    When going in the test/compass all 3 then show ok (se pic) but only 1 work in the HUD.

    Tested all 3 with an arduino sketch and a different board "Pro mini" the all work.

    Another issue, why must the mission planner first have to load the latest software every time i click on hardware tab?

    When doing the live compass calibration, after the 60 seconds it show 0 sec and then stops, have to close MP and restart. i.e it never says compass is done.

    Thanks/Goran

    3692783043?profile=original

    3692782991?profile=original

  • I have been flying for months with no issues on 2.9.1b until I upgraded to 3.0.1. I ran through all the calibrations including compassmot using a 3DR power monitor sensor. I even used anti vibration foam on my APM 2.5+, did a live calibration of the compass and calibrated the gyros. I even recalibrated the ESCs. I have spent 2 days on this. Slowly power up the motors in stabilize mode and on a flat concrete surface, as soon as the is just enough power to lift off........boom, the copter flips over on its back.

    I reloaded the old firmware and bingo. I'm flying great again. I don't know what gives because there seems to be plenty of people flying with rev 3.0.1 and loving the improved stability. But something must be amiss because there are too many reports of the backflip occurring among us experienced APM quadcopter pilots.

    Take a look at the APM blog over here. Several other pilots are experiencing problems with ver 3.0.1 doing backflips on takeoff after upgrading from 2.9.1b

    http://ardupilot.com/forum/viewtopic.php?f=3&t=1870&sid=9ee...
  • Help me May be someone can analyzed my log
    My spec :
    FY tarot 680 
    Arducopter 3.0
    APM 2 RC timer 
    Turnigy Ubec 5 A low RF noise 
    Simonk firmware ESC(i'm not sure the brand and curent)
    AX 2810 750KV
    Turnigy 9XR
    frsky
    Buzzer
    Flighmax 5000 Mah 4s 30C
    GPS Ublox Neo 6 CN 06


    I starting learn this hexa about 1 month ago,, Every night I read from forum to forum
    I'm very insterest about all flight mode in APM,, so I start to learn every flight mode,, Stabilized, Althold, loiter, circle, and RTL,, all in Simple mode
    My fail safe set to RTL( the setting is just turn my remote to decided mode, and press F/S button on frsky)

    when I learn about loiter in arducopter 3 i decided to moved the apm board about 7 cm above the electricity of esc (interference issue , before moved is 80%,,after 49%),, 
    so all cabel place is change,, 3 of 6 esc signal cabel was move to the outside pipe of tarrot,,, 
    AHRS_MPU6K_FILTER is set to 20
    the loiter is very great, very stable than before moved,,
    than I learn about circle,, so I change to 1 Deg/s and radius 5 meter,,( To sloww movement )

    Every flight is nice,, 
    BUT, that morning,, I don't know WHY,, it's Just FALLL,,When remaining time is 1:46(I set my time remain to 10 minute in 9xr )

    I start with : Stabilized - AltHold - Circle - Disarmed until my time 5 minute remaining...
    Fly again,, Arm - Stabilized - alt hold - stabilized - Throtle until my altitude rise about 15 Meter( 1:46 remain),,I dont know what happen,, I focus to my hexa because I see the hexa is hard try to stable from big wind,, and suddenly if I not wrong, one of the motor just stoppppp ,,,,, and falll,, I don't know why no buzzer alarm if lowbatt..

    And I Turn off the Radio( I forgot thats a fail safe mode),, I think when I looking for my hexa The motor is still working ,, and panicc

    After 1 hour i found my hexa,, there is a fire burning the electricity cable, burning one of tarrot arm ,, GPS is broke,, the battery was broken( but there is no fire burning the bat),, APM casing is crash ( but when I plug to USB looks fine),, 

    this is my logg

    I think the problem is 20-24 log
    at 19 log I Disarmed the apm

     Thank U,, Sorry For My englishh

    Archive.zip

    IMG_7682.JPG

    IMG_7684.JPG

  • well I managed to get the vibrations down to a really good level. But now it seems the baro and sonar are slowly drifting apart as the flight progresses. Any Idea why that would happen? Previously they were very tight.  All I did was balance the props and added a few grommets. These logs were the last few test flights I did in my lounge room

    Also what are the left and right graph this buttons for?

    2013-07-24 18-53 1.log

    2013-07-24 18-30-09.tlog

    2013-07-24 18-54 2.log

    https://storage.ning.com/topology/rest/1.0/file/get/3692782300?profile=original
  • Hello!

    About compass_orient:

    I just got new external compass.

    Everythihg is clear except positioning the mag. It is not clear on wiki explained, at least for me, just want to get some help about  this. How should I fix it, without any compass_orient modification? As on apm2.5 itself, is Y axis forward and X axis to right (watching from above), shell this be also for external mag utilized? 

    If I am wright, if you see the att., compass should be placed chips up, pins backwards, Y axis forwards as on apm2.5, and no additional compass_orient setup. Cutting the connection on the board and i2c is all ok to me, only this makes me unclear.

    Thanx in advance!

    magnetometer.jpg

    https://storage.ning.com/topology/rest/1.0/file/get/3692782871?profile=original
  • Hello Randy!
    Thank you very much for your great work! I use the apm 2.5 with arducopter 3.0.1. I am quite happy so long. But there is one thing I miss: A better support for sonar-sensors, especially for the MB1200XL (http://www.maxbotix.com/Ultrasonic_Sensors/MB1200.htm). 

    Do you see any chance for these types of sonar sensors to become integrated in the future releases of the arducopter firmware?

    Thx, 
    Bjoern

This reply was deleted.

Activity

DIY Robocars via Twitter
How to use the new @donkey_car graphical UI to edit driving data for better training https://www.youtube.com/watch?v=J5-zHNeNebQ
yesterday
DIY Robocars via Twitter
RT @SmallpixelCar: Wrote a program to find the light positions at @circuitlaunch. Here is the hypothesis of the light locations updating ba…
Saturday
DIY Robocars via Twitter
RT @SmallpixelCar: Broke my @HokuyoUsa Lidar today. Luckily the non-cone localization, based on @a1k0n LightSLAM idea, works. It will help…
Thursday
DIY Robocars via Twitter
@gclue_akira CC @NVIDIAEmbedded
Nov 23
DIY Robocars via Twitter
RT @luxonis: OAK-D PoE Autonomous Vehicle (Courtesy of zonyl in our Discord: https://discord.gg/EPsZHkg9Nx) https://t.co/PNDewvJdrb
Nov 23
DIY Robocars via Twitter
RT @f1tenth: It is getting dark and rainy on the F1TENTH racetrack in the @LGSVLSimulator. Testing out the new flood lights for the racetra…
Nov 23
DIY Robocars via Twitter
RT @JoeSpeeds: Live Now! Alex of @IndyAChallenge winning @TU_Muenchen team talking about their racing strategy and open source @OpenRobotic…
Nov 20
DIY Robocars via Twitter
RT @DAVGtech: Live NOW! Alexander Wischnewski of Indy Autonomous Challenge winning TUM team talking racing @diyrobocars @Heavy02011 @Ottawa…
Nov 20
DIY Robocars via Twitter
Incredible training performance with Donkeycar https://www.youtube.com/watch?v=9yy7ASttw04
Nov 9
DIY Robocars via Twitter
RT @JoeSpeeds: Sat Nov 6 Virtual DonkeyCar (and other cars, too) Race. So bring any car? @diyrobocars @IndyAChallenge https://t.co/nZQTff5…
Oct 31
DIY Robocars via Twitter
RT @JoeSpeeds: @chr1sa awesomely scary to see in person as our $1M robot almost clipped the walls as it spun at 140mph. But it was also awe…
Oct 29
DIY Robocars via Twitter
RT @chr1sa: Hey, @a1k0n's amazing "localize by the ceiling lights" @diyrobocars made @hackaday! It's consistently been the fastest in our…
Oct 25
DIY Robocars via Twitter
RT @IMS: It’s only fitting that @BostonDynamics Spot is waving the green flag for today’s @IndyAChallenge! Watch LIVE 👉 https://t.co/NtKnO…
Oct 23
DIY Robocars via Twitter
RT @IndyAChallenge: Congratulations to @TU_Muenchen the winners of the historic @IndyAChallenge and $1M. The first autonomous racecar comp…
Oct 23
DIY Robocars via Twitter
RT @JoeSpeeds: 🏎@TU_Muenchen #ROS 2 @EclipseCyclone #DDS #Zenoh 137mph. Saturday 10am EDT @IndyAChallenge @Twitch http://indyautonomouschallenge.com/stream
Oct 23
DIY Robocars via Twitter
RT @DAVGtech: Another incident: https://t.co/G1pTxQug6B
Oct 23
More…