Christian Lopez
  • Male
  • San Luis Obispo, CA
  • United States
Share

Christian Lopez's Friends

  • Bharat Tak
  • Swaroop Hangal
  • Cliff-E

Christian Lopez's Groups

Christian Lopez's Discussions

DEV Support: Purpose of Message Deferment

Started this discussion. Last reply by Søren Kuula Mar 24, 2013. 1 Reply

All- I know this is a specific question, but if anyone can help, it will be much appreciated.First, what happens to the APM/ArduPlane when a Tx serial buffer is over-filled?Second, what does message…Continue

Tags: Serial, ArduPlane2.66, Telemetry, XBee, GCS

Crashing APM 2.0

Started this discussion. Last reply by Christian Lopez Mar 21, 2013. 4 Replies

I have some heavily modified ArduPlane 2.66 code running on my APM 2.0- since my last big series of modifications, my new mode seems to be crashing the board- as soon as I flip into the mode, the…Continue

Tags: Crash, Software

MAVLink connection fails "Getting Params...(sysid 2 compid 1)"

Started this discussion. Last reply by Christian Lopez Mar 11, 2013. 6 Replies

Wondering if anyone has experienced this before.I have changed my sysid (MAVLink's way of distinguishing different vehicles) in the APM_Config.h file for a multiple UAV mission (The other a/c need to…Continue

Tags: sysid, MAVLink

Telemetry Data not flowing through UART0/UART2 telemetry port or Straight UART2 (Bridges cut, and re-soldered)

Started this discussion. Last reply by Christian Lopez Jan 21, 2013. 5 Replies

With APM2.5, I can't seem to get the full Telemetry data to flow out of the Telemetry port. With USB connected I get full telemetry through the USB port, but with power supplied to the input rail…Continue

Tags: UART2, Telemetry, MAVLink, APM2.5

 

Christian Lopez's Page

Latest Activity

Søren Kuula replied to Christian Lopez's discussion DEV Support: Purpose of Message Deferment
"Hi, It looks to me like it is safe against that. But will just send rubbish messages that are not useful if the buffer overflows. Regards Soren"
Mar 24, 2013
Christian Lopez replied to Christian Lopez's discussion Crashing APM 2.0
"Thanks for the pointers- Removed a few unnecessary Serial.print lines, and purged a bunch of float values that I could manage to hold as ints... Now I'm back in business.  Thanks again"
Mar 21, 2013
davidbuzz replied to Christian Lopez's discussion Crashing APM 2.0
"any form of Serial.print('xxxxxxx') is the easiest and most likely culprint, no matter what you are printing or to which port.  the reason is that the 'xxxxxxx' I gave there uses 7 bytes of RAM, permanently, and these…"
Mar 21, 2013
Christian Lopez replied to Christian Lopez's discussion Crashing APM 2.0
"Thanks for the reply- That's definitely something I was afraid of. It looks like you may be right. When I load the stock 2.66 code, I have 1400+ RAM at initialization, but only ~370 with my modified version. Looks like I need to put my code on…"
Mar 20, 2013
davidbuzz replied to Christian Lopez's discussion Crashing APM 2.0
"typically the thing that causes me symptom/s most like the ones you are experiencing is running out of ram. ( SRAM) see here for more clues: http://arduino.cc/en/Tutorial/Memory in-short, comment out all your Serial.print('some debugging…"
Mar 20, 2013
Christian Lopez posted discussions
Mar 20, 2013
Christian Lopez replied to Christian Lopez's discussion MAVLink connection fails "Getting Params...(sysid 2 compid 1)"
"You're totally right- even in mode 2. I believe that is just to escape certain characters (not sure why/if that's needed). I was looking at the output with the MAVLink hidden, but yes- there is definitely the XBee start byte and their…"
Mar 11, 2013
Bharat Tak replied to Christian Lopez's discussion MAVLink connection fails "Getting Params...(sysid 2 compid 1)"
"In API mode 1(which I have been using) we do get the API header and footers on the GCS side, I have not tested mode 2(but xbee-Arduino uses that and claims its better), probably the junk is knocked off in that mode(thats neat!). I'll try that…"
Mar 11, 2013
Christian Lopez replied to Christian Lopez's discussion MAVLink connection fails "Getting Params...(sysid 2 compid 1)"
"Actually, this was an error I caused when I was re-routing my MAVLink messages that were coming from other sysid's... QGCS and APM MP use different sysids (254, 245 I think).It wouldn't connect normally, because it was re-routing the…"
Mar 11, 2013
Bharat Tak replied to Christian Lopez's discussion MAVLink connection fails "Getting Params...(sysid 2 compid 1)"
"Routing your xbee data through mavproxy to APM or qGCS would remove your 'MAVLink connection fails "Getting Params...(sysid 2 compid 1)"' error. The thing is, for some reason Misiion Planner does not handle API trash in the…"
Mar 11, 2013
Christian Lopez replied to Christian Lopez's discussion MAVLink connection fails "Getting Params...(sysid 2 compid 1)"
"CTRL-T seems to take care of the problem."
Jan 26, 2013
Christian Lopez replied to Christian Lopez's discussion MAVLink connection fails "Getting Params...(sysid 2 compid 1)"
"As a follow up to the previous post, I toggled back to sysid=1, and i still have an issue as it reads the parameters. It just gets stuck on different ones.  So, perhaps the modifications I have made have somehow interfered with the parameter…"
Jan 25, 2013
Christian Lopez posted a discussion

MAVLink connection fails "Getting Params...(sysid 2 compid 1)"

Wondering if anyone has experienced this before.I have changed my sysid (MAVLink's way of distinguishing different vehicles) in the APM_Config.h file for a multiple UAV mission (The other a/c need to be able to identify who's sending them messages).When I go to connect to APM Mission Planner to use HIL Sim, the MAVLink connection freezes getting the sysid and compid parameters. I know the connection is going through, because I can see the changes in attitude of my board on the HUD in the…See More
Jan 25, 2013
Christian Lopez commented on Bharat Tak's blog post Comprehensive APM2.5(brand new) Xbee Troubleshooting all available options
"Awesome! Thanks for sharing... I will give that a try as soon as possible."
Jan 22, 2013
Christian Lopez replied to Christian Lopez's discussion Telemetry Data not flowing through UART0/UART2 telemetry port or Straight UART2 (Bridges cut, and re-soldered)
"Interesting- I took a break from this problem to work on other aspects of my project. I'll be circling back around to the issue in the next couple days, and I will let you know if I get anywhere with it. I am hoping to utilize a debugging tool,…"
Jan 21, 2013
Bharat Tak replied to Christian Lopez's discussion Telemetry Data not flowing through UART0/UART2 telemetry port or Straight UART2 (Bridges cut, and re-soldered)
"I am sorry, a correction I had faced similar problem with APM 2.5. - Telemetry was working with USB UART0 but not through the UART0/2 port(when powered by the PWR M&R port and Xbee *plugged, the AUTOMUX pad were as it…"
Jan 21, 2013

Profile Information

About Me:
I am a graduate student at California Polytechnic State University, San Luis Obispo. I am working on a Master's in Aerospace Engineering with a concentration in control systems.
Please tell us a bit about your UAV interest
For my thesis, I am working on establishing a low-cost UAV program to serve as a test-bed for multiple UAV control projects. My hope is to accomplish formation flight via potential function guidance and compare flight test results to simulation.
Hometown:
Sacramento, CA

Comment Wall

  • No comments yet!

You need to be a member of DIY Drones to add comments!

Join DIY Drones

 
 
 

Groups

Season Two of the Trust Time Trial (T3) Contest 
A list of all T3 contests is here. The current round, the Drone Delivery Challenge, is here

© 2015   Created by Chris Anderson.

Badges  |  Report an Issue  |  Terms of Service