Peter
  • Bangkok
  • Thailand
Share

Peter's Friends

  • Hex Air Robot

Peter's Groups

Peter's Discussions

Upload problem using Arduino 1.0 with Arduplan 2.33 on APM2

Started this discussion. Last reply by leachim Apr 20, 2012. 1 Reply

Hello,I just got around to use APM2 that I purchased sometime ago.  I downloaded arduplane2.33 and use Arduino 1.0 to upload the code.  I followed the instruction to add "#define CONFIG_APM_HARDWARE…Continue

HK GCS shows Target Alt = 0.0ft in Auto mode

Started this discussion. Last reply by Mike Nov 7, 2011. 2 Replies

Hi, I am using 2.24 + Remzibi Arduplane code.  When I fly the other plane, it works fine.  However, when I switch to a new airframe.  Whenever I switch to Auto mode, it would try to go to Target Alt…Continue

HK GCS shows Target Alt = 0.0ft in Auto mode

Started this discussion. Last reply by Peter Nov 7, 2011. 4 Replies

Hi Paul, I need your help.  I am using the latest HK GCS program to monitor Arduplan 2.24+Remzibi.  There is a strange output that I see from HK GCS or.  I set the waypoints to be 200m above ground. …Continue

APM 2.20 - Auto mode - losing altitude

Started this discussion. Last reply by Chris Anderson Jul 30, 2011. 9 Replies

APM 2.20 with APM Mega 2560, I only added these lines to APM_Config.h:#define SERIAL3_BAUD        57600#define AIRSPEED_SENSOR     ENABLED#define GCS_PORT      3 In stabilized mode, everything works…Continue

 

Peter's Page

Latest Activity

Peter replied to Simon Atkinson's discussion ArduPilot w/ ATMega328 boards & ArduIMU+ V3 kit in the group ArduPilot (legacy) User Group
"Hello Simon,The last time I played with the ArduPilot (328) was with ArduPilot_2_7 and ArduPilot_2_8 with ArduIMU+ V2 and the result was not better than ArduPilot with Thermopile.  At that time, the developers were busy with making APM1…"
May 10, 2014
Peter replied to Ryan Rasmussen's discussion Can somebody please explain MAVlink?
"Hello Matt, I am not sure if you already got the information you wanted.  Most MAVlink messages are declared on its own file i.e. mavlink_msg_heartbeat.h -- so you can look for encoding, decoding, sending function in those…"
Apr 24, 2013
Peter commented on Krzysztof Bosak's blog post Secrets of Photomapping by Krzysztof Bosak has heen brought up-to date.
"Thank you, Krzysztof."
Mar 23, 2013
Peter replied to Cool Dude's discussion No boot loader installed in the Mega2560 ?
"Hello, I think there is more to the missing bootloader than you might think.  I am in the same situation here.  But when I finish putting bootloader and upload APM firmware.  I notice that the LEDs in the bottom board are…"
Nov 7, 2012
Peter commented on Chris Anderson's blog post Some recent features added to the Mission Planner
"Hello Michael, Nice feature. Best wishes, Peter"
Nov 7, 2012
Peter commented on Chris Anderson's blog post Some recent features added to the Mission Planner
"Does this newest version come with ability to load/save missions to/from a file?  Last I checked the previous version dropped this capability."
Aug 30, 2012
Peter commented on Chris Anderson's group ArduPilot (legacy) User Group
"Last I did was 2.4 for 168 and 2.7.1 for 328.  Is there any other variants that work for these boards?  Please help."
Jun 23, 2012
Peter commented on Chris Anderson's group ArduPilot (legacy) User Group
"I have a number of legacy Ardupilot boards, in fact 5x 168 and 3x 328.  So I would like to ask for your help to locate the right version for 168 and 328.  Last I did the test, none of them worked well in Auto mode.  So I think I like…"
Jun 23, 2012
leachim replied to Peter's discussion Upload problem using Arduino 1.0 with Arduplan 2.33 on APM2
"I have the same Problem here, if i upload it with just #define CONFIG_APM_HARDWARE APM_HARDWARE_APM2 in the APM_Config.h it makes a Bootloop."
Apr 20, 2012
Peter posted a discussion

Upload problem using Arduino 1.0 with Arduplan 2.33 on APM2

Hello,I just got around to use APM2 that I purchased sometime ago.  I downloaded arduplane2.33 and use Arduino 1.0 to upload the code.  I followed the instruction to add "#define CONFIG_APM_HARDWARE APM_HARDWARE_APM2" to APM_Config.h..  The compile and upload are okay.  However, when I look at Serial Monitor, APM2 does not boot up correctly.  It does this:Init ArduPlane V2.33Free RAM: 3976load_all took 10324usPress ENTER 3 times to start interactive setupThen it would come back to "Init…See More
Apr 11, 2012
Peter replied to Peter's discussion HK GCS shows Target Alt = 0.0ft in Auto mode
"Hello Paul,   MAVLink comes with target altitude.  However, now it seems to work fine.  So I think it's a matter of APM not working at certain time..   Best regards,   Peter"
Nov 7, 2011
Paul Mather replied to Peter's discussion HK GCS shows Target Alt = 0.0ft in Auto mode
"I don't believe target altitude comes across in MAVlink. I'm compatible with lots of different protocols and that field is not in use when using APM (I think). What GPS unit are you using? I haven't checked the APM code recently...so…"
Nov 7, 2011
Mike replied to Peter's discussion HK GCS shows Target Alt = 0.0ft in Auto mode
"I've had similar strange issues that I couldn't figure out, even without changing airframes.   After several tries at reloading the firmware resetting everything to default and re-calibrating the radio and all hardware it finally…"
Nov 7, 2011
Peter replied to Peter's discussion HK GCS shows Target Alt = 0.0ft in Auto mode
"Hello Paul, I couldn't see the 3D models. How can I increase the Lat/Lon decimals? From the log, do you see that APM is trying to reach target altitude 0.0ft? But when I get home and switch on Auto mode from my desk, target altitude is 656ft…"
Nov 7, 2011
Paul Mather replied to Peter's discussion HK GCS shows Target Alt = 0.0ft in Auto mode
"Hmmm, do you see any of the 3D models? I just played back your file in 1.3.16 (the most recent version) http://code.google.com/p/happykillmore-gcs/downloads/list and it looks good to me. The only negative is only 5 decimal places on the lat and…"
Nov 7, 2011
Peter replied to Peter's discussion HK GCS shows Target Alt = 0.0ft in Auto mode
"Just to add.  I can read waypoints from 1.0.89 Mission Planner and see that I set the waypoints to be 200m above ground as well.  So I think it's not the Mission Planner.  Please help."
Nov 7, 2011

Profile Information

About Me:
-_-
Please tell us a bit about your UAV interest
Fixed wing
Hometown:
Bangkok, Thailand

Comment Wall

  • No comments yet!

You need to be a member of DIY Drones to add comments!

Join DIY Drones

 
 
 

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service